Jump to content


Photo

Diff lock not fully engaging.


  • Please log in to reply
20 replies to this topic

#1 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 30 July 2008 - 10:35 PM

So I had a new gearbox a few months ago (200 tdi defender)and had a new pinion drive installed cross drilled one but kept the same transfer box as it was fine and working fully.
Recently when I have been at various play days when I engage diff lock the light comes on and the defender drives correctly but when put under load trying to climb out of a bomb hole the diff lock pops out and dis-engages. If you hold the gear level in the lock position it stays engaged. I would take it back to the guy who fitted it but he has moved to the Isle of Wight and wound up his business.

So the question is can I adjust this mechanism to make it work correctly and if so how?

Advise appreciated.

Tj

Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#2 dougstar

dougstar

    Old Hand

  • Settled In
  • PipPipPip
  • 208 posts
  • Location:wirral

Posted 30 July 2008 - 10:42 PM

there is a spline on the top next to the diff lock lever similar to that of a gear shifter on a motor bike,

You could always try moving that around one spline at a time and see if your problem lies there? All will be apparent once you expose the linkage i had to do mine on my disco as it was siezed :o But its easy and make sure you apply plenty of water proof grease to the centre sliding pin when you have it open as this is where my problem lay.

HTH if not someone will shout me down with a better more accurate solution soon enough :P

Dougie

DUST IS JUST MUD WITH THE JUICE SQUEEZED OUT !
96 DISCO
96 XR 400 mint and up for sale sold cheap as chips!
Untill now Have you ever googled your own name?


#3 BogMonster

BogMonster

    Old Hand

  • Moderators
  • 11,831 posts
  • Location:Third rock from the Antarctic - 5141.8'S 5750.5'W

Posted 31 July 2008 - 12:54 AM

I wonder if the difflock switch needs adjusting. I don't know if it affects difflock mechanisms but I do know that an incorrectly adjusted reverse light switch on an LT77 box can make it jump out of reverse, so it might also do the same with the difflock as the switch is the same part.
2002 Discovery II 4.0 V8 auto • 2006 Defender 110 SW 300Tdi • 2011 Ford Ranger XLT crewcab

#4 Marks 110

Marks 110

    Member

  • Settled In
  • PipPip
  • 196 posts
  • Location:scunthorpe

Posted 31 July 2008 - 06:12 AM

I wonder if the difflock switch needs adjusting. I don't know if it affects difflock mechanisms but I do know that an incorrectly adjusted reverse light switch on an LT77 box can make it jump out of reverse, so it might also do the same with the difflock as the switch is the same part.


Is the problem only apparrent with diff lock or is it also happening in low box.I remember a similar problem on my 200tdi (which also had a new gear and transfer box), whilst driving the off road course at Driffield it kept jumping out of low at the most inconvenient time. In the end my girlfriend ended up physically holding the lever in low throughout the duration of the course. To remedy the problem I removed the transmission cover and adjusted the linkage (after geting some excellent advice from Ashcroft Transmissions). I can' remember exactly what I did but I think there was an adjustment nut on the rod which shifted into low, its obvious when you see it anyway. That was about 3 years ago and its been fine since.

Hope this helps,

Mark

#5 101sean

101sean

    Old Hand

  • Settled In
  • PipPipPip
  • 698 posts
  • Location:Middle of nowhere, Co Tipperary & Kent

Posted 31 July 2008 - 06:30 AM

Whip the transmission tunnel off and you will see a wobbly collection of levers and bent rod, that's what makes it work, move the hi/low lever around and it will be obvious. If there is any slop, it won't engage. First make sure that at each of the pivot points there are a pair of nylon top hat bushes, can easily go walkabout when swapping boxes, I lost two. Also the spring clips can corrode and break. If everything is fine, it needs adjusting. There is a pivot post screwed into the side of the Tbox, remove the lever, back off the locknut and and unscrew the post a turn or two. This will throw the lever further and engage difflock.

Try this and report back, hpoefully it will work.
Sean
73FL74 101GS
2000 110 CSW
Medway Military Vehicle Group (Ireland rep!)
www.mmvg.net

#6 Escape

Escape

    Speedfreak

  • Settled In
  • PipPipPip
  • 778 posts
  • Location:Flanders

Posted 31 July 2008 - 06:35 AM

I had been experiencing the same problems, diff lock popping out under load, for some time and gradually getting worse. Last play day it unlocked on a steep descent and made a horrible clunck when powering out of a ditch, so definitely not healthy.
Earlier this week I decided to finally fix it. I removed the transmission cover in the cab (no upholstery anymore, so quite easy) to expose the linkage.
The camplate on the TC contected to the difflock was all but burried under dried up mud, after a good cleaning I still noticed a lot of play in the linkage. I disconnected the link (long vertical one from the stick to the TC), manually moved the camplate to determine the full travel and then adjusted the pivot (which is basically a screw into the gearcase with a nut securing it) and tightened everything up (especially the top bolt connecting the horizontal to the vertical link). It works fine now, with a nice postive 'click' when you engage it and still plenty of spare travel when disengaging.

I should have taken photos, but if it's not clear, just ask and I'll try and explain it better.

Greetz,

Filip

#7 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 31 July 2008 - 07:38 AM

Great, thanks guys sounds like I have a plan for Saturday! Will take photos and report back.
Tj

Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#8 JST

JST

    LRS Sanctuary

  • Settled In
  • PipPipPipPip
  • 6,433 posts
  • Location:Taunton,Somerset

Posted 31 July 2008 - 07:39 AM

as Filip and Sean Say it will be the pivot for the lever that is in the wrong place so its pivoting enough to fully engage diff lock therefore comes out easily. adjust the length of the pivot in the side of the main G box. to do this you will prob need to remove the long vertical bar that works off the pivot which can be more fiddly than imaginable.

i cant remember if you need to increase or decrease the pivot length though.

Its not the splined bit at the top that does Hi /Low

#9 Escape

Escape

    Speedfreak

  • Settled In
  • PipPipPip
  • 778 posts
  • Location:Flanders

Posted 31 July 2008 - 07:54 AM

i cant remember if you need to increase or decrease the pivot length though.


Increase to get better engagement. ;)

#10 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 03 August 2008 - 10:04 AM

HELP!


Ok I cant see which bit i should adjust to make the pivot longer.

Attached Files


Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#11 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 03 August 2008 - 10:06 AM

Or from here?
Linkages feel fine but not sure what i should be moving to increase the pivot point.

Attached Files


Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#12 Madcowz

Madcowz

    Old Hand

  • Supporters
  • 532 posts
  • Location:Innerleithen, Scottish Borders

Posted 03 August 2008 - 10:12 AM

As far as I know, the bit that does the Difflock magic is circled in this image at the bottom.

The pivot is circled in the middle. It is this you adjust to give more/less travel

Don't worry about the bit circled as "missing pin clip" as that was why my difflock wasn't working :-)

Attached File  2008_03_22_High_Low_and_Difflock_selector_arm.jpg   270.52KB   62 downloads

#13 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 03 August 2008 - 10:16 AM

So remove the cover and adjust ?

Attached Files


Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#14 Madcowz

Madcowz

    Old Hand

  • Supporters
  • 532 posts
  • Location:Innerleithen, Scottish Borders

Posted 03 August 2008 - 10:20 AM

No, sorry.

I have updated my image showing the right bit.

#15 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 03 August 2008 - 10:36 AM

Ok, cool.
I think I have sussed mine as your picture had a missing split pin and at the bottom of my rod I noticed it was not fully moving across as I had a missing split pin from the rod. I moved the link arm up and it freely moved passed the bolt on top of the camlink cover and engaged diff lock fully!

Hurray now just to fit the new tiny split pin and take for a test around the farm.

Thanks chaps.

Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#16 smacsor

smacsor

    Member

  • Settled In
  • PipPip
  • 61 posts
  • Location:Bristol

Posted 03 August 2008 - 11:35 AM

So remove the cover and adjust ?


This finally prompted me to get up off my ar** and see wht my difflock isn't work (it's never worked - had the vehicle a few months) and this photo was perfect!!

On mine the small round bar at the bottom of the pivot arm that is supposed to be connected to the camlink.......aint connected at all!!!

How does this bar fix to the camliink. It looks like its fractured on mine....is it all the same part as the camlink. Any ideas on part numbers?

Ta,

SimonAttached File  DSCF0047.JPG   765.9KB   31 downloads
1985 90 2.5P (Lily)
2002 Disco TD5 Adventurer (Doris)

#17 western

western

    Recovery Man

  • Moderators
  • 28,580 posts
  • Location:Cornwall,UK

Posted 03 August 2008 - 11:42 AM

the finger that is sticking up just needs to be twisted & fitted the the hole of the plate,

Attached Files


Ralph, M3WRM, MSA Recovery Operator -- Western Recovery [Motorsport] http://www.amro.org.uk/
Defender Forum Moderator

Keep LR4x4.com Independent -- you can help by Clicking Here

#18 smacsor

smacsor

    Member

  • Settled In
  • PipPip
  • 61 posts
  • Location:Bristol

Posted 03 August 2008 - 11:58 AM

the finger that is sticking up just needs to be twisted & fitted the the hole of the plate,


Thanks for that Ralph, but looking more closely, the finger has fractured off leaving a bit fixed in the camlink which just spins round. So I assume I need to fit a new "finger"? Do you know the part number for that? How does this locate in the cam link? Feeling around beneath the bit left it, it feels like there's a tiny split pin in there? So will I need to remove the camlink as fell to fit the finger to it?

Many thanks,

Simon
1985 90 2.5P (Lily)
2002 Disco TD5 Adventurer (Doris)

#19 TJN

TJN

    Old Hand

  • Supporters
  • 257 posts
  • Location:Micheldever

Posted 03 August 2008 - 12:11 PM

Having spent this morning swearing at mine I would say don't move the cam plate cover , wiggle the broken bit of "finger" out of the way.
You may beable to order replacement finger and pins from Ashcroft Transmissions.

http://www.ashcroft-...o.uk/index.html

Going to play in mine now!

Good Luck.

Typical that the smallest part causes the most grief!

Tj
1990 Defender 130 Expedition vehicle.
Chairman Hampshire and Berkshire 4x4 Response.


#20 western

western

    Recovery Man

  • Moderators
  • 28,580 posts
  • Location:Cornwall,UK

Posted 03 August 2008 - 12:15 PM

Thanks for that Ralph, but looking more closely, the finger has fractured off leaving a bit fixed in the camlink which just spins round. So I assume I need to fit a new "finger"? Do you know the part number for that? How does this locate in the cam link? Feeling around beneath the bit left it, it feels like there's a tiny split pin in there? So will I need to remove the camlink as fell to fit the finger to it?

Many thanks,

Simon


new part is FRC7948 up to chassis LA939975
clip is FTC3674
split pin is PS103121L

You can remove the cam plate, as it has 2 flats so will only refit one way.

hth :D
Ralph, M3WRM, MSA Recovery Operator -- Western Recovery [Motorsport] http://www.amro.org.uk/
Defender Forum Moderator

Keep LR4x4.com Independent -- you can help by Clicking Here




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users