Jump to content


Photo

srs airbag light


  • Please log in to reply
4 replies to this topic

#1 davie1

davie1

    Member

  • Settled In
  • PipPip
  • 30 posts

Posted 13 October 2010 - 11:59 AM

Hi guys,
have an annoying problem for the last few months, my srs airbag light comes on and stays on unless I do a journey of 30 - 40 miles, then it goes out and will stay out for a few days only to return and stay on when using for short journeys. Any ideas would be greatly appreciated as electrics are not my strong point. Going to get her up on my mates ramp next week to waxoyl the bottom and service her before she gets treated to new boots.
Cheers
Davie
97 "P" 2.5 TD (Met Red) on coils
Alfa GT

#2 Range Rover Blues

Range Rover Blues

    Not the world's greatest typist

  • Settled In
  • PipPipPip
  • 978 posts
  • Location:Yorkshire

Posted 13 October 2010 - 11:21 PM

I've been told that the airbags are meant tp last 10 years and thet system knows when they "expire" so the light comeson when they need replacing. Don't know how much truth there is in that and I can't afford Rovacom to sort mine out.
Range Rover Classic LSE 5.0
Range Rover Classic TDi "Chuggaboom"
Range Rover Vogue 3.9 "Blue" with many toys & a GKN-Sankey Rapier

#3 Clive

Clive

    Member

  • Settled In
  • PipPip
  • 61 posts

Posted 15 October 2010 - 11:17 AM

Both my 1994 classic Range Rovers with airbags were/are over 10 years old and still had/have the original airbags. The SRS light still works normally and doesn't stay on after 7 seconds.

It appears as if it could be any component and you may need to use Rovacom to find out which. Otherwise you could try to get some air bags and ECU off the internet and try swapping them out one at I time. When you find out which one is causing the problem then you can sell the other two back on the internet!

However I would hazard a guess that it might be the ECU.
Clive

1994 Range Rover LSE
1994 Range Rover Vogue (Scrap - bulkhead rotten!)
1987 Range Rover Vogue EFi (Awaiting restoration)
1991 VW Golf Country Chrom Edition

#4 Range Rover Blues

Range Rover Blues

    Not the world's greatest typist

  • Settled In
  • PipPipPip
  • 978 posts
  • Location:Yorkshire

Posted 15 October 2010 - 06:10 PM

Both my softies (all 3 in fact) have had the SRS system dissabled which is why I asked about the light to be told the thing about 10 years. Can't affod the unit for Rovacom yet or I'd have it sorted.

If you replace the ECU there are 2 types that are very similar, the RRC only used the extenal sensor type, the Disco had both depening on year.
Range Rover Classic LSE 5.0
Range Rover Classic TDi "Chuggaboom"
Range Rover Vogue 3.9 "Blue" with many toys & a GKN-Sankey Rapier

#5 plasticbadger

plasticbadger

    Old Hand

  • Settled In
  • PipPipPip
  • 870 posts
  • Location:New Forest, England

Posted 15 October 2010 - 06:49 PM

The SRS light comes on in my Disco 2 reasonably often and my '99 peugeot. It's normally the connections under the seats to the pressure sensor that's to blame. It could easily cause your symptoms, i.e. after a while running the dodgy connection gets hot enough to make a circuit, then it takes a while to loosen again. I'd try fiddling with that before getting into ECU swaps.
Rebuild project - 1999 Chevrolet 3500HD 4x4 - for when bigger just isn't biggerer enough
Daily driver - 1999 Disco 2 Td5 - high mileage long term abuse experiment
Mrs PB daily - 1996 Disco 300 Tdi - 400 mile per week tatty bus survival test




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users