Jump to content


Photo

TD4 FUEL PROBLEM


  • Please log in to reply
3 replies to this topic

#1 FLASH

FLASH

    Member

  • Settled In
  • PipPip
  • 34 posts

Posted 27 April 2011 - 08:26 PM

05 td4 started running rough on tickover yesterday then today would not start this afternoon after doing about 200 miles. Changed fuel filter which has only made it worse it will now only start after turning over about twenty seconds my thinking is air leak between tank and pump or knackerd pump which is only two years old does anyone have any other ideas ?.

#2 Chris Sargent

Chris Sargent

    Member

  • Settled In
  • PipPip
  • 28 posts

Posted 28 April 2011 - 09:56 AM

Could be one or more faulty injectors, MAF, crankshaft sensor or a fuel pressure regulator - or the the fuel pump as you said.

You can test the injectors using two tests:

1. The leak off test - do a google search.
2. Pull off each plug from the injectors one by one. When you pull off the electrical plug, there should be a noticeable difference in the running of the engine. If not, it suggests that injector is faulty.

MAF - just try disconnecting it and seeing if it makes any difference.

Fuel Pump - try holding steady revs at 4k whilst stationary. If it splutters or does seem to be able to hold steady revs, could suggest the fuel pump.

Crankshaft sensor - will give rough running across the rev range I think.

If all else fails then it could be the fuel pressure regulator on the end of the HP fuel rail. First off, check that the connection to it is fine and clean - unplug and plug it back on a few times and also wiggle the wires whilst the engine is running to see if it's damaged - this is a known fault. Otherwise, there are some seals that fail on it and the only way to check is take it off and have a look. I believe you can get a new seal kit.<br>

#3 FridgeFreezer

FridgeFreezer

    Director of authenticity

  • Supporters
  • 17,097 posts
  • Location:Gosport, UK

Posted 28 April 2011 - 02:37 PM

I'd vote crank sensor as #1 suspect, if this is knackered then nothing else matters.

MAF it should run with it unplugged. Injectors unlikely as it'd need more than one to stop it dead.

I've heard TD4 fuel pumps are a point of failure but don't know the symptoms, you can listen for it running but bear in mind the ECU may not turn the pump on until it knows the engine is turning (crank sensor etc.)
Yes*
*No

#4 FLASH

FLASH

    Member

  • Settled In
  • PipPip
  • 34 posts

Posted 28 April 2011 - 05:38 PM

Thanks for the replys think i've sorted it changed pump which made no difference, then bypassed water trap and all the crappy pipework(the push on fittings really are a carp idea) and it runs fine so ordered new trap and pipework for next week will keep fingers crossed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users