tobac

2001 Freelander rear window problems.

3 posts in this topic

I have a 2001 Freelander and it has been parked in a garage for 5 weeks while I was on holidays. When I returned the battery was flat and the rear window was down even though it was up when the car was left. After charging the battery I still could not put the window up. It will go up then immediately return down by itself. On checking the manual it talks about synchronising the window by cycling it up but it keeps going down again. I feel it may have something to do with the alarm but all other alarm functions work OK. I have checked the door lock to make sure it is closing OK. Eventually I removed all of the rails, motor, etc for inspection and nothing seemed out of order. I disconnected the battery for 10 secs and discovered to my surprise that all was working OK. I reassembled the window mechanism.

I thought I solved my problem but I have not. Window appeared to work ok so I reassembled the motor and rails, etc. When I hooked the power up everything now works in reverse. The inside switch works the wrong way. The key in the door only drops the window. The window will lower to the bottom and when you open the rear door is raises slightly. When the window is closed it will not lower to open the door. When you alarm the door the horn blows once to signify something is not closed. If you lower the window and leave it there the alarm works correctly and the horn does not blow. It appears it is synchronised 180 degrees out. I have tried disconnecting the battery for 15 seconds but nothing changes. Has anyone any suggestions.

Share this post


Link to post
Share on other sites

For what it's worth I had a similar problem when the battery on my 04 reg TD4 failed last year. On connecting the battery the rear window went down so I raised it up with the switch in the car and it seems to be OK. I then locked and unlocked the car a few times. It's been OK since.

incidentally does this help you? http://www.lro.com/forum3/viewtopic.php?f=20&t=44233&start=10

Share this post


Link to post
Share on other sites

Now you won't believe this but the Freelander has a mind of its own. After trying every thing that I could think of I decided to remove the motor outer cover on the rear window. I wondered if maybe it was on the wrong way. However the wiring cable meant it would only fit one way. So I replaced the cover back as it came off. I reconnected the cable. He presto everything worked as it should. Don't know what I did but maybe the wiring cable on the motor needed to be disconnected while the battery was connected. Who knows what happened. Just wasted 2 days sorting this problem out. Makes me wonder what the Landrover dealer would have done as they said replace the whole regulator etc at an enormous cost. Only cost me time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now