Sign in to follow this  
Followers 0
Thorny

Fuel gauge problems.

10 posts in this topic

Would be very grateful if anybody could shed some light on this issue for me. It's a bit complicated so I'll explain the situation as easily as I can.

The vehicle in question 1986 110 diesel.

The vehicle is in the latter stages of a complete restoration.

I have installed a new fuel tank as part of the restoration project, Tank mounted on small rubber bushes to absorb vibration.

The original fuel gauge has been re-used.

The vehicle has been completely re-wired.

So, that's the background. Now for the problem...

I have a new sender unit. 3 terminals on it, the same as the old original. 1- Earth

2-Gauge

3-Low fuel light

With the earth terminal earthed directly back to the battery and the remaining two terminals correctly connected, the fuel light illuminates when the float is in the up (tank full) position. The fuel gauge however reads full regardless of the position of the float.

So...

I took the old sender off the old tank just to try it...

Fuel warning light works correctly with this sender, but the fuel gauge still reads full regardless of the position of the float.

I should say that prior to the restoration, the gauge and warning light both worked accurately.

I have spent hours fettling different combinations of wires in case I had mistakenly put the wires onto the wrong terminals but to no avail.

My limited knowledge of the dark arts of electrical wiring has been exhausted.

I would greatly appreciate any help with this matter.

Thanks in anticipation.

Share this post


Link to post
Share on other sites

have you tried to earth the gauge?

later defenders have a daisy chain of earths across the gauges, the fuel reads full if its not connected. Not sure how it works with older models but worth a shot if not all ready considered.

G

Share this post


Link to post
Share on other sites

are the gauge wires connected correctly ?

earth goes to the long thread in centre of gauge rear face & jumps to each of the other gauges then into the wiring loom multi bullet connector.

Share this post


Link to post
Share on other sites

Thanks for the input gents. So far as I understand the wiring is correct Western. The earth is daisy chained across the gauges, I have to admit to assuming that as the needle was moving the earth must be okay. I'll go back and check that thanks. I'll also double check the wires as per Westerns guidance.

Once again, thanks for your help.

Share this post


Link to post
Share on other sites

on the tank unit the connections are

black sleeved terminal to gauge

red sleeved terminal to low fuel light

the earth is the threaded/rigded stud in between the 2 sleeved terminals, a female single bullet connection is a good fit on here.

Share this post


Link to post
Share on other sites

I spent bloody weeks and numerous trips to flamin A&E trying to sort out a similar problem. Turned out the tank itself had a baffle in the wrong place and the float was jamming against it..... Pattern tanks, be wary....

Share this post


Link to post
Share on other sites

My '95 Hard top doesn't have the low fuel warning light (blacked out in the warning light panel) and I'm changing to the later panel. Can I just change the float unit for one with the low level warning (+wiring) ? What part number am I looking for?

Thanks

Malcolm

Share this post


Link to post
Share on other sites

Yes plus you might need to run a wire from sender to gauge. or there might be a wire witin the loom you can use [white/slate colour code IIRC.

I think this sender PRC4262 is for 90 with low fuel light. -- check with supplier before spending any cash. genuine LR version is nearly 3 times the price.

Share this post


Link to post
Share on other sites

It's fixed!!!

Sirocco, you hit the nail on the head! Thank you!

The fuel gauge now reads correctly and the fuel light comes on when the tank is almost empty!!! (at flippin last!)

The solution was.....

A missing earth lead on the gauge was an issue :unsure: With that sorted I still couldn't get either of the new sender units to work correctly. Low fuel light coming on with a full tank etc.

I have managed to repair the old sender sufficiently to re-use it. Not ideal but at least everything now works as it should.

Thanks for the help and advice offered. :i-m_so_happy:

Share this post


Link to post
Share on other sites

My fuel gauge has always lied.

When it says that it is 1/4 full it really means that you have run out of fuel!!!

It caught me out a couple of times when I first got it,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0