Jump to content

Reg

Settled In
  • Content Count

    91
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Reg

  • Rank
    Member

Contact Methods

  • Website URL
    http://
  • ICQ
    0

Profile Information

  • Location
    Cyprus

Previous Fields

  • Interests
    My Landrovers 1955 S1 Hybrid, 1984 S111 Safari:bits donor, 1998 P38<br />and my boat 1980 Coronet 24 Sport with twin 130 HP Volvo Inboards.

Recent Profile Visitors

245 profile views
  1. My rangie has been laid up for a time and was down on the stops having been left gathering dust. When I fired it up and reset the windows etc I took it round the block but the suspension refused to budge. A check on the diagnostics box showed both offside sensors out of limits. The compressor was persuaded into life but it still failed to respond. I gave up and ordered a set of airline over ride valves and started pricing height sensors; then had a little brainwave. Trolley jack under offside sill, jacked up untill both wheels were hanging free. Then fired up the engine, wherupon the nearside rose to meet the height of the offside on the jack and when I dropped the jack the offside pumped up to match. This may not be an original idea but it certainly solved the sensor issues.
  2. Reg

    servo

    I have a Lockheed type scrapyard remote servo on my S1 which is fitted with s3 pedal boxes on a cut down s3 replacement footwell section. The servo is marked Benditalia which means it probably came off a Fiat or Alpha. The servo has been working fine for nearly 10 years, I have a 109 front axle with twin brake cylinders so the car used to stop well. Last week due to oil and brake fluid on the shoes I started a brake rebuild using some spare rebuilt backplates and new hub seals all round. At the same time I upgraded the front hubs and shafts to the later versions with identical innner and outer wheel bearings. The 3/4" master cylinder was replaced and then problems started. I found if the pedal freeplay is set properly a fully returned pedal lets the next press down to the floor. If the lash is taken out then I get a firm pedal and good brakes after a few pumps but then the brake pressure builds up and locks up the brakes whilst driving. Replacing the new 3/4" cylinder with another does not show any improvement. I have ordered a S2A LWB master cylinder which is bigger as this seems to be the cause of the problem, a recon lockheed servo is also due in the post. I am puzzled by the way the pedal drops to the floor if the freeplay is removed and hope that using a bigger master cylinder is the correct solution.
  3. My series 1 which is fitted with a 4 bolt Adwest has been marking it's territory so I took it off. As I did'nt have the chunky circlip pliers it was delivered to my local friendly garage. The box was disassembled and fitted with new seals on the sector shaft.....but the adjuster screw on the casting was siezed so the seals were damaged trying to reinsert the shaft splines several times against the side pressure without success. Eventually the hot axe came out and released the screw but with damaged seals it just made the mot test and then started dumping fluid again. I have now got 2xseal sets so we will try again, including the autosol treatment on the shaft. Incidentally, the bottom bearing is a caged roller not a bush. I am contemplating machining up a bronze bush replacement with an internal O ring to add a further seal to the line of defence if it continues to leak after the next operation.. I have now also found out that the seals can be removed without stripping the box, remove the circlip whilst still on the Landie and the pump will push out the seal if the steering is cycled, sounds a bit messy though. Alternative on the bench is to drill the washer under the clip to fit a couple of self tappers and use pliers to get it out. (There is a new one in the kit.) Getting the washer off without one of the above get arounds is frustrating and nigh impossible, we tried magnets, tweezers screwdrivers, picks etc all failed in our first attempt. Dropping the box is dead easy on my S1 it takes 20 minutes as the wings are externally bolted into a tapped aluminium angle plate so I can sit on the tyre to unbolt the heavy lump once the wing is off. Recon boxes in Cyprus cost an arm and a leg and shipping one from UK adds another leg.
  4. If you wind out the longitudinal link this will create a lop sided steering, you will have to compensate for this by recentering the drop arm and/or idler arm this will give you more travel and may restore your turning radius. It is possible that a bodger tried to sort the steering by winding in the link to try to allign the steering instead of setting up the drop or idler arm. If you suspect the steering has been messed with, it is worth taking down all the links, disassemble the ball joints from the shafts and check that they are the right ones for your axle. I remember (vaguely from 6 years ago when I sorted mine) that some ball joints have tapers on the L and R threads, they are not interchangeable and a taper to a parallel link can cause thread fretting. Not a good prospect if your ball joint drops out of the shaft. PS I have found this method to set the tracking after work without the services of a special tool. Get a length of plastic conduit about 15mm, insert a smaller diameter wooden dowel about a foot long into the plastic tube. Pack it out with a couple of rings of insulating tape if necessary to get a good sliding fit. Cut the plastic to length so that it will fit across the chassis between the fronts of the rims with the dowel free to move in and out. Nail a panel pin into the dowel about 2" from the end to stop it getting lost in the tube!! . Re set your tool at the front of the rims and mark the dowel with a pencil where it enters the conduit and note F (front) next to it. Now repeat at the rear of the rims. Mark again and compare the pencil marks this will give a pretty good indication of your starting point toe in/out. Now adjust the track link and do it again 'till you have got it right. Roll the landie forward a yard and repeat your measurements..... Simples! Now you have a working tool, remove the dowel, glue or nail another length of dowel onto the tube full length, less the length of the measuring dowel. Insert a light compression spring into the space between the two pieces of dowel. Cut a slot in the adjuster end of the plastic for about 2" stopping 1" from the end of the tube. Insert a screw/nail or some form of pin through the slot, into the sliding dowel so it cannot fly out across the workshop. Now you will have a spring loaded tracking tool which will stay in place while you set up the link.
  5. If your compressor was on it's way out, it would normally be heard from the driver's seat continually cutting in and out you will notice the noise most when you pull up from speed and the pump has to raise the body height from cruise height. A good pump will raise the body quite quickly . If the pump has been working hard to keep up with a system problem it will wear out the pump compression ring. If your car suddenly sank it could be a defective bag/pipe OR the seals on one of the solenoid valves inside the box, if this gives up the line to it's bag will depressurise. Check your plastic pipes for wear or melting near the exhaust heat. It is very easy to replace the piston ring or the whole piston, ring and cylinder liner and there are good online help instructions as posted above. All parts are available from ebayuk. The pump comes out after disconnecting the outlet pipe, the power plug and the three mounting bolts, make sure you reinstall them the right way up. If rubbers are looking less than pristine, buy new ones with the other bits. Unless you are used to playing with motors and alternators do not try to strip the motor end to inspect the brushes, you will need a lot of patience and a bag of swearwords to get it back together.... unless you know the tricks. When you replace the piston parts, ensure the grub screw on the conrod locates on the flat of the motor shaft, otherwise it will work loose and slip, motor turns, no pump reciprocating. My garage installed pump second hand lasted about 8000 miles before it started making wierd noises caused by poor assembly of the grub screw. I normally keep a rebuilt pump in my spares box, then it is a 10 minute job to make the switch over.
  6. Hi, living in Cyprus my S1 can get hot under the hood when standing in the sun, I have got round the problem by fitting some stainless steel woven tube over the fuel pipe which on it's S3 engine runs over the thermostat housing to add to the heat gain. The tube is the cheap pipe that you get to connect water taps under the sink at home, cut off the ends slip it over and tidy the ends up with a bit of coloured insulating tape. Another thought would be to put a computer fan next to each carburettor. I have had to resort to tipping a bottle of water over the carb which does the trick instantly, so windscreen washer jet strategically placed might fix the job elegantly. Once when the engine stopped and wouldn't restart on our local boat launching slipway I was holding up a queue of other boaters. I lifted the bonnet, poured a plastic bottle of water over the carb and restarted .... much to the astonishment of a German tourist. "You pour water in ze engine, she start how does zis work?
  7. A bit obvious but have you checked your batter connections? To avoid the battery off issues, next time the battery refuses, tap the terminals with a LIGHT hammer to rotate the terminal on the post (if it has round posts) or up down with rectangular posts. I have fitted a female kettle type plug lead across the terminals of all my cars, the matching computer plug is fitted on my Halfords maintenance charger instead of croc clips (the car's lead is coiled up next to the battery when not in use.) If the car is standing long I just pop the bonnet pull out the lead and join up the connectors then I can drop the bonnet with the leads in place without the problem of clips popping off or contacting the bonnet. Now it's a doddle to keep the battery charged and no excuse to do it tomorrow. The lead is not suitable for high rate charging!!!!! My series 1 has a built in plug fitted to the seat box with an inline fuse for good measure. The plug came off the back of a dead computer.
  8. I presume you mean that the last numerals have been stamped in a place where the metal has been ground down, possibly to conceal a change to VIN number. The VIN number is also shown on a card below the windscreen in a rectangular cut out made in the screen interior trim. The VIN may have been changed because the chassis was damaged and a substitute second hand chassis or partial chassis welded on. I hope the following helps: "The VIN number is on the outside of the right front chassis leg, the panel in the front windscreen and a the sticker on the front slam panel." " The tamper resistant VIN in the front windscreen can only be changed by taking the windscreen out. " The BECM also normally has a record of the VIN number as the P38 can communicate with the central Landrover records by some electronic system at main dealers, this informs dealerships about recall work which would have been carried out when the car was new. After I bought my first used P38 the main dealer matched the car with the factory records and they found several recalls which had not been done. Numbers 12 to 17 are the vehicle production serial numbers. Below is the NAS version of how to read your VIN plate, How To Read Your VIN Number
  9. I understand that in the interest of originality, some series owners wish to persist with the Zenith Carb. My S1 is fitted with a S3 engine and the ex army engine came with a Webber Carburettor which had been mangled by the wrong idle screw being fitted. I bought a Webber copy for around £70 and it ran straight out of the box, decent fuel economy and 5 years later still performs well, except for running on occasionally when the engine is hot, not helped by 95 octane leadfree petrol. I am beginning to get compression loss on one cylinder so the spare hard seated head will have to be fitted soon. Because the S3 petrol engine sits high in my engine bay the bonnet interferes with the air cleaner plumbing. I have a pancake filter at the moment but this is suffering from foam fatigue and a replacement cannot be sourced. To overcome the height problem I have been contemplating an SU replacement a bit like the beautiful solution installation shown in the photo post. But I need to cut down the height a bit or the SU will make dents in my Bonnet, is there an SU with a Horizontal intake? Can the float chamber body be indexed around to do this?
  10. I have owned a 2 door Classic and 2 P38's. In a simple comparison, the Classic seemed quicker and more nimble but it had a noisy manual gearbox and the seats were uncomfortable compared to the P38 HSE. My current Vogue "model" has manual seat adjustment and no lumbar cushion so not quite as good. The Classic body roll was epic, many a time the roundabouts were taken on the doorhandles, that is probably why they adopted flush handles from the BL parts bin. The P38 is better on corners especially with uprated shocks but I would hesitate to throw it into a bend like the old Classic. My first P38 was a 4.6 HSE and gave little trouble over 3 years after it had been sorted through for recalls that had not been done. Give them their due, Mann Egg fitted a new drive plate, changed hoses fixed the sunroof and a number of other problems showing on the factory records for free!! And they did'nt sell me the car. I never had any overheat issues but the Air suspension did pack up and I fitted a new box for £350. That was a bargain at the time. My current P38 has a new Coscast 4.6 fitted, together with a couple of chips in the ECU. She is very fast when provoked, particularly in the 70 to 90 acceleration band, tailgating Mercs eat my dust. When I bought the car it had a 4.0 lump which had died from the usual cracked block issue, hence the choice of the Coscast replacement. I have a Blackbox Solutions diagnostics system to sort out the computer issues plus a spare rear 4 pin dif just in case.
  11. Last Sunday my Rangie refused to lift off the stops and it was making a strange intermittent squeeling noise from the air box. I parked her up and we used the OH's car. As there was a rebuilt spare in the garage I set to on monday to change it. The worst job was refitting the rubber bushes in the feet because I had a sore thumb. Having got the air to work I started stripping the old pump with a view to putting it right with a few bits. After removing the end plate I discovered that the crank was freewheeing on the shaft because the last mechanical genius had failed to locate the grub screw onto the flat, so it had eventually worked loose and started to slip. Lesson: If you replace the piston ring check the allignment of the shaft flat is opposite the access hole in the casing before fitting the con rod. If you leave the grub screw protruding a mil or two it can only locate into the flat. A small dab of locktite will also help but too much will weld it in for next time. The crankcase was coated with fine filing dust from the casing so I think the chances of reviving this particular specimen are remote. I hope that the filings won't show up in my valve block! Next stop ebay for a spare to rebuild. I also removed the motor casing to check the brushes, does anybody have a workable system for reassembling it? I spent half an hour with various methods of jamming the brushes in the open position so that the end cap would slide on. Two thin split pins eventually solved the job but there must be a better way.
  12. Hi , this is a very useful thread, I have dreaded having to get someone to weld my silencer or something similar as the usual response in Cyprus is to say " we disconnect the battery, don't worry we always do it this way!" Does disconnecting the ECU also isolate the other computers such as the transmission, can any other sensitive parts be fried? So If I disconnect the ECU and ensure that the earth cable of the welder is connected onto the workpiece, the risks will be minimised. Except from fire of course!
  13. The gasket you changed is not the head gasket (there are two of these,) it is called the valley gasket or inlet manifold to head gasket. I agree that it is likely that the visible bubbles are air, if it was steam you would have a very hot header as the steam would condense in the coolant and raise it's temperature. Try bleeding the system before you suspect something more serious. Removing the water pump and inlet manifold will have let the coolant drain completely and this is replaced with air which can hide in all the "nooks and crannies" (places to trap air) PS Please excuse my alterations to your text, it might help others to follow it more easily.
  14. With a good battery the P38 will normally try to reset a bad door lock by repeating the sequence, i.e. the locks will click, pause, lift click, pause close click. The trouble with this is as I found on my 1st HSE was that due to a sticky tailgate latch, the process repeated ad infinitum , stupid computer didn't know when to give up!!
  15. These procedures are for the P38 but may help with the later models, unless you get help from an expert, try the following: Get a full report from the LR garage as to what the fault codes and readouts were, what they did to rectify the problem, why the fix did not work and what parts of the suspension they inspected. Basics; If it sinks overnight the bags seals or pipes are at fault check for leaks with soapy water, look for cracks on a high setting. If it dropped on command but stayed down, the ecu or height sensors are a likely source of the problem. If you drive on a low setting the ECU will probably shut down and refuse to play, you will need a suspension jogger or a Blackbox interface with a laptop to diagnose and reset the fault (or keep spending at the garage.) I would blame a height sensor if you have been playing with the buttons. The height sensors are a variable resistor connecting the body to the axle via a link bar, it sends a signal to the ECU to tell it how high the suspension is, if it gets damaged or sticky the reading will be false. (The diagnostic would point to this as a fault normally.) If the system fault is intermittent it may be an ECU or a wiring or earth problem, unlikely with a 2004 car. Unless you have had leaking system, the pump should be fine, unless the sensor does not shut it down and it carries on pumping. You should be able to hear of feel the vibrations of the pump if it is working too long. Why did they change the tank? If the tank was changed, did they use the old fittings and pressure switch or did they replace the complete module as the easy option to solve a pressure regulation problem? I suggest you get a set of airline inflater valves, connect them into the air pipes as instructed and blow up the suspension one at a time, at least you will be able to keep going until the fault is cured. Not sure how the system is connected up and works on your car (Try ebay )
×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy