Jump to content

Search the Community

Showing results for tags '1990 110'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • International Forum
    • Modified Vehicle Builds & Special Projects
    • Getting out and about
    • Competing in Land Rovers
    • Tools and Fabrication
    • The Video Shack
  • Tech Archive
    • Land Rover Technical Archive
    • Requests for Part Numbers
  • Vehicles
    • Series Forum
    • Defender Forum
    • Freelander Forum
    • Discovery Forum
    • Range Rover Forum
    • Military Forum
    • Evoque Forum

Calendars

There are no results to display.

Blogs

  • LR90's Blog
  • geoffbeaumont's Blog
  • My 1991 RRC 4.0 V8
  • Doublecab Happenings

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello all, My 1990 110 2.5TD has developed a fault with the aux fuse keeps popping. It's the top left one, and should be powering the horn, back fog light (?), this also affects the light stick when pulled back to put full beam on for a few seconds. The voltage is 12.8 when the engine is off. Any ideas on what to check or try? I'm guessing an earth wire somewhere or a short of some sort. Checked and it's marked as 20amp and have been putting in a 20amp fuse. I've checked with new light Indicator-horn-headlamp dip switch Disconnected all the connectors in the engine bay for the water pump Swapped the hazard switch for another one Removed the other switches such as lights and heated window (which was not connected to anything :D) No cigaret lighter or USB connectors on either All and any helpful suggestions welcomed.
×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy