Jump to content

Search the Community

Showing results for tags 'cpo warranty'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • International Forum
    • Modified Vehicle Builds & Special Projects
    • Getting out and about
    • Competing in Land Rovers
    • Tools and Fabrication
    • The Video Shack
  • Tech Archive
    • Land Rover Technical Archive
    • Requests for Part Numbers
  • Vehicles
    • Series Forum
    • Defender Forum
    • Freelander Forum
    • Discovery Forum
    • Range Rover Forum
    • Military Forum
    • Evoque Forum

Calendars

There are no results to display.

Blogs

  • LR90's Blog
  • geoffbeaumont's Blog
  • My 1991 RRC 4.0 V8
  • Doublecab Happenings

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. samusc

    Evoque Turbo Problems

    Hello! This is my first time posting here and would appreciate your feedback. I own a 2014 Evoque with CPO warranty. Last monday (seven days ago), i realtzed that the car was feeling very sluggish and would not accelerate as it should be. So i took it to the dealership and they told me that they would need to diagnose the vehicle. I asked them for a loaner vehicle for the time being and they informed me that they were out of any loaner vehicles and specifically because i had a walk in appointment it would be difficult for them to give me one. The advisor told me that he would let me know in a day or two as to what the issue is and we could proceed from there. I guess i was too nice and agreed to everything he had to say. He did not get back to me in 2 days and i tried to call the dealer ship but wasnt able to get through the right person and they told me they would get back but that did not happen. Cutting the chase, finally after 6 days the advisor got back to me and said that it seems like a turbo problem. He mentioned that he is trying to talk to the dealership to understand whether this is covered by CPO warranty or not. If it wasnt covered then it would cost me approximiately $6000 which is crazy expensive! Can you please advice me as to what i should do at this point in time? Thanks for your assistance in advance.
×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy