Jump to content

Search the Community

Showing results for tags 'led lights'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • International Forum
    • Modified Vehicle Builds & Special Projects
    • Getting out and about
    • Competing in Land Rovers
    • Tools and Fabrication
    • The Video Shack
  • Tech Archive
    • Land Rover Technical Archive
    • Requests for Part Numbers
  • Vehicles
    • Series Forum
    • Defender Forum (1983 - 2016)
    • New Defender Forum (2020 onwards)
    • The New Ineos Grenadier
    • Freelander Forum
    • Discovery Forum
    • Range Rover Forum
    • Military Forum
    • Evoque Forum

Calendars

There are no results to display.

Blogs

  • LR90's Blog
  • geoffbeaumont's Blog
  • My 1991 RRC 4.0 V8
  • Doublecab Happenings

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. Evening, The indicators failed this evening. They were fine on the outward journey but once the battery isolator was turned back on and the ignition turned on the trailer light on the dash illuminated and neither the hazards or indicators work. With the ignition off, turning on the hazards just illuminated the trailer light continuously on the dash. The actual lights do not flash. I have LED lights all round except the side repeaters. any ideas?
  2. So my white Defender with all LED lighting is apparently invisible. I'm always having people pull out in front of me, including these two in the last fortnight. Seriously thinking of fitting more led strips behind the grill so it glows white. Or maybe just make it look like the Coca Cola truck! Accident 13-02-18 edit.wmv Deathwish 23-02-18 edit.wmv
  3. Hi all, first ever post so bare with me, I have a 2001 td5 110 defender. I've just changed all the lights on my defender to led's, some were already leds but the front indicators and headlights weren't and what had been done looked to be a bit of a bodged job, now since installing, (all wires soldered), I'm now getting the rear fog light symbol on the dash whenever I put the right indicator, side lights, main beam on, although the fog light itself isn't on. The rear right indicator is less bright than the rest, (which from what I've picked up on would suggest a bad earth), all the rear lights
×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy