Jump to content

Search the Community

Showing results for tags 'scraping'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • International Forum
    • Modified Vehicle Builds & Special Projects
    • Getting out and about
    • Competing in Land Rovers
    • Tools and Fabrication
    • The Video Shack
  • Tech Archive
    • Land Rover Technical Archive
    • Requests for Part Numbers
  • Vehicles
    • Series Forum
    • Defender Forum
    • Freelander Forum
    • Discovery Forum
    • Range Rover Forum
    • Military Forum
    • Evoque Forum

Calendars

There are no results to display.

Blogs

  • LR90's Blog
  • geoffbeaumont's Blog
  • My 1991 RRC 4.0 V8
  • Doublecab Happenings

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi there, New to this forum so be gentle! I’m looking for some advice about my 04 Defender 90 Td5 - I get a metallic scraping scratching noise at about 30mph when I’m setting off - seems to be coming from left hand side fwd wheel but can’t place any closer than that! I’ve checked for rubbing on the wheel, and had a root around behind it but have yet to see any cause. My next thought is whether the wheel bearing is worn which I’m going to check this weekend when I’ve got time (hopefully!) but was wondering if anyone out there has had a similar problem or knows what else it could be? Thanks!
×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy