Jump to content

Search the Community

Showing results for tags 'thermo top'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • International Forum
    • Modified Vehicle Builds & Special Projects
    • Getting out and about
    • Competing in Land Rovers
    • Tools and Fabrication
    • The Video Shack
  • Tech Archive
    • Land Rover Technical Archive
    • Requests for Part Numbers
  • Vehicles
    • Series Forum
    • Defender Forum
    • Freelander Forum
    • Discovery Forum
    • Range Rover Forum
    • Military Forum
    • Evoque Forum

Calendars

There are no results to display.

Blogs

  • LR90's Blog
  • geoffbeaumont's Blog
  • My 1991 RRC 4.0 V8
  • Doublecab Happenings

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. I got it a while back as a refurbished unit but for various reasons I've not managed to fit it yes. i set it up for testing and can't see where I'm going wrong, it's hooked up to a strong battery and connected as per the instructions. I've never usedd one before so I'm not sure what it's meant to do, the first time I fire it up after a rest it buzzez for a bit then the pump kicks in, gets faster, coughs a bit, makes some horrible noises and then dies. After that it runs horribly rough and never seems to spark. I've uploaded a couple of videos of it if anyone is feeling charitable and offering some advice that would be much apreciated https://youtu.be/XIAt_H2GgQw https://youtu.be/69_7lSl4LP4
  2. cosmin.ardelean

    Starting Webasto Thermo Top Z/C

    Hello again. I am having some trouble with two heaters. I wanted to do a gift to my good friend from UK and the perfect gift for him it's a auxialiary heater. I found on internet a Webasto auxiliary heater (not W-bus or K-bus controlled) and I bought one. The seller ensured me it can be started with +12V on Pin1. The story is complicated, in the end i received not one but 2 Webasto. When i receive the package, my worst fears came true. One heater is BMW Thermo Top Z/C, the other one is Thermo Top C from VW. Both can be started only with the car's K-bus. The seller does not answer to my calls anymore, so i'm on my own. My question: what can i do to start the webasto? A new universal control unit is out of question, since the price is already high. Do you know a good priced second hand control unit? Or do you have any advice for me? Thank you.
×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy