CJ1

1.8 Petrol Running Lumpy Help please?

Recommended Posts

CJ1    17

Hi, I am hopefully buying a 3dr Freelander 1.8 petrol. I know what a lot of people say, but this will be my 4th. Loved them all including my Range Rovers and Discovery's.  Anyway, it is petrol, really low mileage, less than a year ago it has had the uprated head gasket and uprated parts fitted professionally, it is now idling lumpy which can according to the seller be felt at low speeds.  No oil or coolant loss, no blue smoke. The coil packs have been replaced, new spark plugs fitted.  What else could it be please?  I am taking a bit of a chance on this one, hoping it isn't going to be a swing and a miss lol Cheers.  (2001 X Reg)

Share this post


Link to post
Share on other sites
PatM    1

Is it oscillating? Doe the revs go up slight lightly and back down on tick-over? When my MGTF did this (same engine- K-series) it was the pre-cat lamda sensor.

Also, an air leak after the throttle-body can cause the ECU to attempt to adjust a lean mixture.

The MGTF Crew have loads on K-series engine- google MG FORUMS and go to MG-TF and start browsing. 

Share this post


Link to post
Share on other sites
Bowie69    382

Also HT leads, at this age anything can happen.

Share this post


Link to post
Share on other sites
CJ1    17

I bought the car. The misfire really is minute.  I plugged diagnostics in, it came up with misfire due to low fuel, (Needle was very low!) And misfire on cylinder 2 detected.

Spark plugs, ht leads, coil packs replaced, and removed and made no difference.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now