Jump to content
tomplm

P38 Electronics Gurus - help need

Recommended Posts

I have a P38 that I am having loads of trouble with. When it has run it was ok, but intermittent. The more I have tried to fix it the worse it has got. It now has no spark and it won't talk to hawkeye. We tried a recoded "unlocked" Ecu but it has made no difference. It's had new plugs, new crack sensor, new llamas sensors, new coil pack. It turns over, there's fuel pressure in the rail. We tied buzzing through the wiring loom , even changed the OBD connector, cleaned the bcem connectors, etc etc. Nothing! Still no hawkeye cons and no spark. Any ideas?

It's a '95 4.0 V8 with the GEMS ecu

 

 

Share this post


Link to post
Share on other sites

Have you checked the wiring to the crank sensor ?  With my P38 GEMS it was the crank sensor that was the cause of all my problems as it is the only sensor that the GEMS has no default settings for!

Peter

Share this post


Link to post
Share on other sites

Check the grounds to the GEMS ECU.

Is it only the GEMS you can't connect to, or also the ABS?

Share this post


Link to post
Share on other sites
1 hour ago, tomplm said:

new crack sensor, new llamas sensors

That may be my favourite typo so far :lol:

  • Haha 2

Share this post


Link to post
Share on other sites

Do you get power from the ODB port? If not check fuse 32 or 33, 5 amp, in engine bay.

Share this post


Link to post
Share on other sites
Just now, task said:

Do you get power from the ODB port? If not check fuse 32 or 33, 5 amp, in engine bay.

And if that's fine, check the connector behind the kick panel, it has a tendency to corrode if there's any water ingress.

Share this post


Link to post
Share on other sites

There is a 6 or 7 way splice in the pink/red wire from pin 7 of the diagnostic socket.It is in the loom pretty much underneath where the heater matrix O rings leak. Easy to test if its corroded,just do a resistance test between any of the ecu's which use the diag port and are connected to pin 7.From very distant memory that's pretty much all of them except the EAS ECU. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy