Jump to content
SALFA07

Since battery was pulled off, electrics windows don't go up automatically

Recommended Posts

Hi All! On my Freelander 2 I had some parts replaced, hence the battery was pulled off. Once all put back together, my automated electric windows don't work upwards - so with long pull they don't go up.

This is valid for all 4 windows unfortunately - does anyone have any idea what the cause can be? Everything else that is electric works perfectly!

Cheers, David

Share this post


Link to post
Share on other sites

Hello SALF07

Have you checked your fuse box, sounds like a blown fuse ?

 

Chris h

Share this post


Link to post
Share on other sites

Need to reprogram. At least it is this for cars. Hold the switch to get the window up all the way and hold for a sec or two. Window motor may make a slight noise. Car now knows where the top is again. Do for each window.

Share this post


Link to post
Share on other sites

Just to clarify, wind windows to fully open from closed. Release switch and Wind windows fully up and hold for 3-5seconds.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy