Jump to content

Front crank seal gone


NeilF
 Share

Recommended Posts

Did a 300 mike trip yesterday. This morning the oil light came on. Put a liter in and it went nowhere, the oil is horsing it out. Looks like the front crank seal. I’m guessing it’ll need the radiator pulled out to get at it? A lot of work for a 4.50 seal .....

Link to comment
Share on other sites

Griff,

Thanks for that. I doubt I'll do that myself, can't be arsed these days and I don't have a 340lb torque wrench either. But I'll pass this on to my garage guy. Just wondering about the faff of holding the crank still while undoing the bolts - can you not leave it in gear?

Link to comment
Share on other sites

My usual garage gut is off on his hols so I took it to another place who said something about a 'cover plate' that usually cracked and they replace it as a matter of course, than he started talking about a new oil pump too.......

Any Idea what this cover plate is?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy