Jump to content
ian_s

bringing a neglected series back to life

Recommended Posts

Done the cam belt today, but I have a horrible feeling that I've got the pump 1 tooth out as its chucking out smoke, which smells like unburnt diesel.

Annoyingly I started the engine with the front cover off, and I didn't notice any smoke, but I did notice that I hadn't put the oil cooler back and so it was pumping oil all over the place!

Then I refitted the radiator and inter cooler, so maybe there was some oil splashed into the intake pipes and that's causing it to smoke. I didn't run it for long as it was late and I don't want to upset my brothers neighbours.

Share this post


Link to post
Share on other sites

Had a chap on another forum recently swear blind he'd done the timing correctly with pins etc and couldn't figure out why it was smoking like crazy. Eventually he conceded and checked the timing... One tooth out. Easily done. Ran like a charm after he got it right the second time.

Share this post


Link to post
Share on other sites

yep, i think i'm going to have to strip it all back down again 

Share this post


Link to post
Share on other sites

spot on, i was one tooth out on the pump :(

and in stripping it down again i wrecked the timing cover gasket, so had to order one in to the local main stealers, and on the way to collect it I had a stone hit my windscreen and crack it. so this was a bloody expensive error

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy