Jump to content
Sign in to follow this  
jimconline

Intermittent High Speed Blower

Recommended Posts

Any thoughts as to why the blower runs intermittently on high speed? Sometimes when I switch from low to high it works; other times it doesn't. If I leave it on high it will start and stop when it feels like it. Low speed always runs. I've tested connections from the fan control (replaced a couple of years ago) on the dash through to blower motor; no issues noted.

Share this post


Link to post
Share on other sites

Probably the switch, but the reality is you need to troubleshoot with a meter when it happens.  Step one, get the wiring diagram and understand it.

Share this post


Link to post
Share on other sites

As mentioned, I tested connections from control through to blower; I have and understand the wiring diagram. Problem is it cuts out and comes back on so randomly and quickly I can't catch it when it's off. As you suggest, I'm thinking it's the switch.

Share this post


Link to post
Share on other sites

Testing when the fault is not occurring is of no use.  The switches are not very well designed.

Share this post


Link to post
Share on other sites

Problem was the harness connector at the blower motor. I had suspected this early on, tested it, cleaned it, and all was working until recently. Finally decided to recheck and was able to get the high speed fan to stop and start by wiggling the connector. Obviously only the pin for the high speed line was compromised since the low speed fan never failed. Will replace plug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy