Jump to content
Sign in to follow this  
Stellaghost

Electrical issues

Recommended Posts

Hi All having some electrical issues with my 300 tdi discovery fog lights won't work and then they do work but stay on regardless of light switch position I can take switch apart and they stay on interior lights come on and off at will and near side headlight adjustment motor going all the time unless lights switched off unsure as to whether all these problems are linked any advice gratefully received thank you

Stephen

Share this post


Link to post
Share on other sites

Hi, I don't have the 300TDi, but when unexpected things go wrong with the D2's, the first place we look is at water ingress into the wiring -especially the fuse boxes.

HTH,

Griff

Share this post


Link to post
Share on other sites
18 hours ago, Stellaghost said:

Hi All having some electrical issues with my 300 tdi discovery fog lights won't work and then they do work but stay on regardless of light switch position I can take switch apart and they stay on interior lights come on and off at will and near side headlight adjustment motor going all the time unless lights switched off unsure as to whether all these problems are linked any advice gratefully received thank you

Stephen

I assume that will be the rear fog lights and not the front, if so they are controlled by the vehicles multifunction unit (MFU) along with the interior light delay, key and lights on buzzer which are the obvious issues, plus a few other things like delay wash wipe, the MFU has a diagnostic test function ( Google for that) and check that the MFU is function correctly first as it’s a simple test done from the drivers seat.

if okay then move on to checking earth connections, the main one in the engine bay plus the ones behind each kick panel in the footwells.

D1s don’t normall suffer with dampness in the fuse boards unless the vehicle has been in water that deep but then u are in trouble elsewhere.

Share this post


Link to post
Share on other sites

Thanks for that teabag swapped cream mfu  for black one fogs on all the time but lights alarm came back so think I need to source a cream mfu unfortunately mfu will not start its diagnostics life would be boring if things went right all the time

Share this post


Link to post
Share on other sites

I don’t know what exactly the updated cream MFU difference is other that it has the timer circuit provision for vehicles with a heated windscreen if fitted.

Ive seen a couple of posts saying the black replacement for the cream item had been fine.

i had to replace my  MFU in 2012 as it failed completely, £138 from Rimmer bros back then, so 15 years or so for an electronic unit that’s powered 24/7 is good, could be better maybe, depends on its use.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy