Jump to content
td5defender

Td5 refusing to start now...argh!

Recommended Posts

Hi all, i am yet to be convinced there is a problem with the starter solenoid or starter at this stage. If i bypass the starter circuit by applying 12V directly to the blade terminal on the side of the solenoid the starter fires normally. The engine either fires momentarily or not all in this case. The issue is that I am not getting 12V at the solenoid blade terminal wire (the main feed to the starter solenoid is geting permanent 12V as normal). The fault that is stopping 12V getting to the blade terminal is also interfering with the engine running. Possible alarm ECU fault or issue in the starter circuit? Given the ECUs worked fine in another vehicle maybe points to a starter circuit issue?

I would be happy to pull the starter out and inspect the starter solenoid, but cant see the point at this stage when signs pointing elsewhere? Sure worth it given it works perfect if i throw 12V at the solenoid blade terminal?

Just to respond to a few suggestions directly: yes tried locking/unlocking a few times, will find out if any ECU codes came up when tested, no flashing red light on speedo cluster - get steady red light, then light goes off and stays off when unlock car with key fob plus flash of hazards,  have not touched fuel filter / fuel system, checked ecu earth and earth straps under vehicle all cleaned and reinstalled, crank sensor wires confirmed connected. Referred to Haines manual 5.7 Section 8.

I haven't seen the red light on the speedo flashing recently but remember it used too?

I'm going to have to get this towed to a pro unless anyone has any final ideas I can try?

Share this post


Link to post
Share on other sites

Agree with your assessment of the starter. 

Have you checked the starter relay?

Row of relays just above the fuses in the cab.  2nd or 3rd in from left dependant on vehicle spec. All the yellow ones are the same so you can swap to test if needed.

Simple check is fuse cover removed, fingers on the relays and turn the key and feel if the relay click?

If not, it’s either the relay or something else breaking the circuit, potentially your secondary alarm system.

 

Share this post


Link to post
Share on other sites

I would struggle to work through this without an electrical diagram. I have one for 97MY which I know is a little older but the circuit sounds the same as yours. I will at least try to explain how it is connected but the end is that I think it is alarm or immobiliser related and not directly electrical.

1880109391_ScreenShot2019-03-16at13_20_24.png.8ba1089fdeb90812238aa70b8e82d081.png

 

You said right at the top of the thread that if you remove the BO coloured wire from the "RELAY-STARTER" R102 coil and ground that pin (86), then the starter will spin (ok not for long). When you reconnect then it won't.

As you can see the "ECU-ALARM" unit is controlling that ground connection and if it isn't providing that ground on the BO wire then it must not be trying to.

If you look at the load side of that relay - the WR wire from the Crank position on the IGN switch is routed through the relay but doesn't go direct to the "SOLENOID STARTER MOTOR", to routes through the "ECU ENGINE IMMOBILISATION". So even if you can energise the starter relay (as you did), the starter motor solenoid won't operate unless the immobiliser allows it (or until it prevents it, which seems to be what's happening).

 

This text is taken from the Defender Electrical library - a pdf is easily found on the internet

376667995_ScreenShot2019-03-16at13_49_02.png.f069299611ac24ae41fc9a1bacb15f67.png

517738295_ScreenShot2019-03-16at13_19_51.png.8bdea7d2df09a41c012eaf99e6111224.png 

 

So I'd say that the first stage of the problem must be that the alarm ECU isn't allowing the relay to energise. When you force it to then the Immobiliser stops the feed to the starter anyway.

IMHO it must still be associated with these two units. 

 

Share this post


Link to post
Share on other sites

Hi again, and thank you for the comments. I think we are on the right track with diagnosing the problem. It makes the most sense to me given the symptoms. My only nagging doubt is that these units worked in another vehicle... but what we are seeing in my Td5 does seem to point to one of these two units...

If we take it that there is a problem with the alarm ECU and/or immobilisation function of the engine ECU, then that raises the question of how do I best resolve this issue? At the moment I have a 2 tonne piece of fine art work stuck in the garage!

On the starter relay - Yes I did swap over the starter relay with a new one but it made no difference. It is not "clicking" when I try a start which I believe will be because the immobiliser is stopping it going to ground so the circuit is not being completed? On this note,  I can hear a relay clicking under the driver seat when I turn the key to position III. 

 Any ideas on how to resolve this probable ECU issue would be much appreciated. Thanks for the support with this!  Cheers Scott

Share this post


Link to post
Share on other sites

I would think but I'm no expert, from the alarm / immobiliser texts in the manual, that this is the Alarm ECU not happy and so also flagging this to the immobiliser. The text also talks about using the EKA code to reset it if for some reason the ignition barrel sensor thing isn't doing the job.

I obtained my code from the LR Dealer when I provided proof of ownership.

P.S. sent you a PM

Edited by Peaklander

Share this post


Link to post
Share on other sites

There is a earth block on the right hand upper bulkhead in the engine bay. Just double check it has a good contact. That will definitely stop it starting 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy