Jump to content
Troll Hunter

Defender 300Tdi engine bling

Recommended Posts

I don't usually bother myself with bling, but I'm slowly progressing my ground up rebuild and am considering, and only considering, repainting the engine block.  Can someone tell me what colour the block would have been when new, since all trace of paint seems to have long gone.  All body panels have been done in their original Alpine white.

Many thanks for any and all replies.

Mike

Share this post


Link to post
Share on other sites

I believe the 300tdi block was/is gloss black originally, 

Turners Engineering have black blocks on their 300tdi units.

Share this post


Link to post
Share on other sites

My LR Genuine Parts service exchange block (happened before I got it 20 years ago, guess the timing belt went with the previous owner), is a silver grey colour.

Share this post


Link to post
Share on other sites

The block on mine 300, bought new in March 1994, was black

Share this post


Link to post
Share on other sites

 

Here is my 300TDi re-power kit prior to fitting, fresh out of the factory crate (LR Genuine Parts).

 

780204903_NEWENGINE1.thumb.JPG.ad48a82a454b6797f25d09cb3795b347.JPG2144055226_NEWGEARBOX1.thumb.JPG.110ae0a2624f63a9475450a071b7a9cf.JPG

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Well, thank you, all.  It looks as if it will be glossy black, if it ever gets blinged.  I must admit, Litch, that your "new" engine package looks wonderful.  It's quite a change that 20+ years of use achieve.  I suppose that it's just like us getting older.

Anyway, thanks again for your replies.

Mike

Share this post


Link to post
Share on other sites
Posted (edited)

I had a LR genuine parts exchange 300tdi about ten years ago which had the worst paint job imaginable from the factory, it appeared to have had a bucket of grey hammerite dumped on it from above covering everything, head, inlet, block, timing case and sump,  before the application of Genuine Parts decals and dataplate. It was all peeling off the alloy parts when it arrived, ten years on it has almost all fallen off!

Edited by oneandtwo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy