Jump to content

Its stopped working!!!!!!


Recommended Posts

Hi

I run a 90 with a 3.9 EFI V8 engine and auto box out of a discovery and it has stopped working.

There is no live to the fuel pump which I suspect may be a failed relay. However the strange thing is that when I rigged the fuel pump so there was a permanent live (and the pump was working!) it would still not start. I have checked and there is spark.

Any ideas anybody?

Thanks.

Link to comment
Share on other sites

The fuel pump does not get switched on until the ECU "sees" some air flow at the airflow meter, on flapper you can poke the flap with your finger and the pump will come to life. On Hotwire (which I'm guessing your 3.9 would be) I dunno but I'm guessing the fuel pump's not the issue here. For the rest of it, have a search of the forum for EFI problems as it's been gone over a hundred times before in many different ways. Nige (Hybrid_From_Hell) has posted up some very good tech over the years. Paul (Corrode_Finger) has just successfully mated a 3.9 Range Rover to a defender body and I know he really enjoyed the wiring bits & may be able to share his trauma with you :lol:

I'll list the obvious:

- Are the injectors firing?

- Have you got fuel pressure? (cut the fuel return line, this goes from the pressure regulator, and splice in a clear inline fuel filter so you can see fuel returning or not)

- Any fuses blown?

- Have you done anything to, with, or near the vehicle recently?

- Has it been installed by J.Random land rover "expert" who splices the loom together with scotchloks and sparky tape so it will run just long enough not to be his problem anymore?

Let us know if your system is flapper or hotwire as the diagnostics are different for each. As much info as possible makes it easier for people to help you. Using the search button first makes us more inclined to help you ;)

Oh and out of morbid curiosity, can you post a photo of the wiring? :P

Link to comment
Share on other sites

Mousieur Fridgette is right.

There are links on this site I have given to hiom and he has uploaded for all to download for 3.5 and 3.9 diagnostic manuals.

Its YEARS since I had a HW system, but from memory

1. the fuel pump is switched on / off via the ecu I think pin 16 ?

2. Shoving 12v to the FP will make the fuel pump run, but the ecu won't be sensing it

3. check FP Relays, earths, and fuse between wiring to FP +

4. Feed wire from FP to Pump is wire 87 on main FP Relay

signal I think is ECU 16 to FP Relay 85

Basically with a HW switch on ign listen for Zzzzzzzzzzzzzzzzzzz Click, if no Zzzzzzzzzzzzz or Click FP is not being triggered via ECU

HTH

Nige

Link to comment
Share on other sites

Hotwire is a fussy system, it has more sensors than the flapper. If you don't have a wiring diagram I'm sure we can find one.

Assuming the fault is that there's no fuel, or the wrong amount of fuel, going in there are a few things that can be wrong:

If the injectors are firing, the fuel pump is running but little or no fuel is going in, suspect the fuel pressure regulator stuck open. Likewise if it's chugging out black smoke and stinking of fuel the FPR could be stuck shut.

Check the ECU connetcor - is it tight & locked in properly. Are the pins dirty, wet, corroded? If so, get some PCB or contact cleaner from maplins/RS/TV repair shop and give 'em a good scrub with that and a toothbrush.

The ECU needs to see some airflow, so check the AFM connector. Depending on the wiring (can't recall off the top of my head) you might also be able to measure for voltage supply at the AFM connector.

The ECU needs to see the engine turning, this is from the coil -ve terminal so check that connection (white/black or white/blue wire). No signal from the coil and the injectors will not fire.

So, now the ECU knows the engine is turning it will know to stick some fuel in, but it needs to know how much. Apart from the airflow it also needs to know:

Coolant temp - sensor is front left of the plenum, screwed into the inlet manifold if you look from in front of the car. If the sensor is duff it may fail open circuit (infinite resistance) or short circuit (zero resistance) or just somewhere with the wrong resistance. One way the ECU will think it's freezing and flood the engine, other way it will think the engine's warm when it's not and give it insufficient fuel to start from cold.

Throttle potentiometer - black round thing with 3 wires on the side of the plenum mouth. The Lucas systems rely on these being calibrated, it should be 0.325v from the green wire(-ve) to the red one (+ve).

Link to comment
Share on other sites

Possibly a stupid suggestion but it has caught me out on autos in the past.

Is there a switch/sensor that only allows the engine to be started if the gearbox is in park?

Which leads to the questions

Is it in park?

Is the switch/sensor duff?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy