Jump to content
jordan_meakin

V8 RRC - still trying to diagnose problems

Recommended Posts

Hi all.

I'm enjoying my RRC but still have the stuttering that I mentioned on a previous post.  I have realised that it seems to do this at a certain point in the pedal travel.  If I take it easy, or boot it, it runs fine but it means I have to drive like a granny or a lunatic (albeit that's fun).  Could this be a sign of a bad throttle potentiometer?  The only contrary indication is that it doesn't do it when cold but that idle is a little erratic whilst cold...

Any advice welcomed.

Share this post


Link to post
Share on other sites

If your MAF working OK? That's how mine would drive if I forgot to plug it back in....

Share this post


Link to post
Share on other sites

So, I cleaned the MAF - no change, also had the stepper motor off to clean. Not a lot to be seen there but cleaned nonetheless.

Yesterday I fitted a new ignition module, the three pin type. I am sure I've wired it up correctly as the destructions suggest but now it won't run! Any ideas??

Share this post


Link to post
Share on other sites

So, back up and running today.  It turns out that the Bearmach instructions that come with the part are incorrect! The connector block is labelled 1, 2 and 3.  The instructions say - goes to 1, + goes to 2.  In fact, + goes to 3!  Unfortunately, it hasn't solved the previous problems although, the idle is better by chance almost.

Share this post


Link to post
Share on other sites

After much arsing about, it appears to be the throttle potentiometer. Currently it's unplugged and running like a dream. Not sure what'll happen if I continue to run unplugged but the replacements are damn expensive!!

Share this post


Link to post
Share on other sites

Can you measure the resistance of the pot and get a 50p stock one off the internet then make a mount for it?

Share this post


Link to post
Share on other sites
6 hours ago, Cynic-al said:

Can you measure the resistance of the pot and get a 50p stock one off the internet then make a mount for it?

Not sure the exact resistance would matter as it's just acting as a voltage divider, the linearity might matter more, and the flapper system is fussy about the "resting" voltage hence the setup to adjust the pot to a certain voltage at idle.

By contrast, MS only cares about the rate of change (stamping on the pedal) for acceleration enrichment, and wide-open (pedal to floor) for flood-clear mode during cranking.

Share this post


Link to post
Share on other sites
57 minutes ago, Cynic-al said:

I guess the angle of rotation has to be right too?

Doesn't really matter for fuel only, Flapper & Hotwire don't know the angle they just trigger off the coil -ve... most of the time you're squirting fuel against the back of a closed valve anyway, and it's bank or batch fire (4/4 or all 8 at a time). It doesn't need over-thinking, after all the carb just pours fuel down there constantly like a leaky bucket :lol:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy