Jump to content
Freerangechicky

Freelander won’t start in the cold weather!

Recommended Posts

Hi guys, my Freelander 1 1.8 petrol won’t start easily in the mornings now the weathers cold, it’s taking me about 10-15 mins...once I’ve got it started it’s completely fine all day. Any suggestions what the fault is?? Thank you!

Share this post


Link to post
Share on other sites

What year?

My money is on the crank position sensor (pretty sure they all had one) or a failed coolant temperature sensor, but they usually fail "rich" rather than than "lean".

You might check for spark from a plug lead to confirm if the coil / a coil pack (depending on year) is getting weak.

Share this post


Link to post
Share on other sites

A sniff of easy start will tell you if you have spark. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy