Jump to content
Matt2e0fgx

How warm ?

Recommended Posts

How warm does or should a disco 2 run ? Mine is only 1/4 - 3/8" above the white line by the cold and heater is not hot but pretty warm . 

Any ideas what this could be ? Thermostat  , air lock , water pump , blocked heater matrix ? 

Share this post


Link to post
Share on other sites

should run with the guage in the middle of the sweep

 

heater on full chat should be Hot,

does the temperature come up when you give it a bit of a hammer?

 

Share this post


Link to post
Share on other sites

My 2004 TD5 runs with the temp gauge half way up. Do the hoses get hot? especially the top hose. If not, first suspect is the thermostat. Make sure it's replaced correctly.

Griff

Share this post


Link to post
Share on other sites

Replaced correctly ? What you mean ? 

Never took one apart on a d2 so wouldn't know what looks like . One done a o ring or a seal around the thermostat that pushes into housing and a gasket or o ring to seal . 

Share this post


Link to post
Share on other sites

My car gets toast warm and sometime I cannot stand how hot it is in the cab and need to reduce the temperature.

I do like it hot most of the time.

Share this post


Link to post
Share on other sites
15 minutes ago, Matt2e0fgx said:

Replaced correctly ? What you mean ? 

Never took one apart on a d2 so wouldn't know what looks like . One done a o ring or a seal around the thermostat that pushes into housing and a gasket or o ring to seal . 

thermostat is best described as being heart shaped, it is mounted to the radiator cowling between the top & bottom hose essentially , 3 hose clips & easy to change,

Share this post


Link to post
Share on other sites
On 12/12/2019 at 6:18 PM, Matt2e0fgx said:

Replaced correctly ? What you mean ? 

Never took one apart on a d2 so wouldn't know what looks like . One done a o ring or a seal around the thermostat that pushes into housing and a gasket or o ring to seal . 

If you look at the thermostat you'll see there are 2 ports on one side and one on the other. Make sure you get the 2 port side the correct way round.

 

s-l640.jpg

Share this post


Link to post
Share on other sites

I thought that would be obvious ? You take it off and replace pipes to where came off . I did replace the water pump at the weekend and I run after without the viscous fan on and the gauge did raise to midway in the gauge.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy