Jump to content
Sign in to follow this  
92a

200tdi issues

Recommended Posts

Hi all , got a 200 tdi in my series , just changed the cambelt as its been standing for a while before being reconnected and fired up but now it ticks over but won’t rev , does not smoke it’s got no air filter on so it’s not that 🤔 any ideas ? Angus 

Share this post


Link to post
Share on other sites

Hi all again , tried the fuel pin ( if that’s the one under the domed cover ) and it’s free , also tried a fresh tank of fuel and a filter full of Redex, but still would not rev , on fully opened throttle it tried to rev but died off,. I’ve robbed the pump off my defender and it revs up fine with  that, Anything else to try on the pump or is it time for a new pump ☹️☹️

Share this post


Link to post
Share on other sites

I would take it to a diesel injection specialist for repair. to valuable to scrap.

Share this post


Link to post
Share on other sites

Have a look at this.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy