Jump to content

All Spark and No Bark

Recommended Posts

Starting a new thread specifically for this issue to keep things clear.

I cannot get a spark out of my MS no matter what I try, so any input whatsoever would be welcome.

GEMS 4.0 from a P38

Intermotor coil packs

Nigel's MS/EDIS kit


The only way I can show what I might have wrong is to show everything I have done. Bear in mind everything is loosely fitted until I get it working, so don't judge too harshly.

Relays are wired as below. Ignore the FPR pin 85 wire, that is going straight to the battery negative for the time being so I don't need the ECU connected to operate the relay. The power for ECU pin 29 comes directly from the same ignition switched live connector on my fusebox that feeds the relays, there was just no point in making it go fusebox - relay - ECU when the fusebox and ECU are next to each other.


Blue/Yellow wire is getting power to Pin 6 of the EDIS and injectors are getting power (confirmed with a Noid light). Fuel pump and coil pack is getting power from pin 30 of the FPR. All of that says to me the relays are activating and supply the power to where it's meant to go.

These are the wires on the EDIS and as you can see, all are accounted for in some way. The VR plug is the right way around, the joints are properly soldered and have continuity (LED at the sensor end with a positive charge down the EDIS end to prove which pin terminates where and they are continuous - no possibility for error!). The VR sensor is 1mm from the wheel and is centered properly over it.


From ECU/EDIS to engine. 12v confirmed at the coil end of the white/purple wire.


The wires go to the plug like this:


...Which is what was agreed in my other 4.0 topic in this section. And having worked it out four separate times to see if I'd got it wrong, this is definitely what the info says it should be.

I have replaced the coil pack, I have replaced the leads and I have replaced the VR sensor. I have bought a spark indicator light that sits on top of the spark plug just to eliminate the possibility that I wasn't getting a good ground with it held against the block. Nothing.

I've spent over £100 chasing this fault now and getting desperate. Please tell me where I've gone wrong, as I fully accept I have - I will just never see it!

Edited by ThreePointFive
Link to comment
Share on other sites

Personally I would make use of the one, in my view, redeeming feature of EDIS - it doesn't need an ECU to run the ignition.

Get rid of the MS ECU, remove it from the equation altogether, forget about it until you have the ignition working. Connect the EDIS to 12v, -ve, the coil packs and the VR sensor. See if you have a spark when the engine is cranking. If not then disconnect all but one of the coils and try that. If you have a scrap place handy locally and can get access I'd even consider having a look for an old Fiesta and grabbing an Edis-4 unit off that for testing purposes to eliminate a fault with the EDIS-8.

With no ECU connected an EDIS-8 should happily run the ignition for you without any input from an external ECU. If you have a means of displaying/reading it it would also be useful to measure the output on the PIP wire as that will tell you if the VR sensor is doing it's job properly. You might get a feel for it with a DMM as you should see it pulsing as it's a 12v signal and any pulse would suggest that the VR sensor is doing something. No pulse at all and your VR sensor isn't wired properly or is faulty or is wired back to front.

Link to comment
Share on other sites

Spare EDIS8 unit is on its way now :D

And just to double-check, here's working EDIS wiring:

Plug on the right numbers 1-12 left-right;

  1. PIP to ECU p24
  2. No connection
  3. SAW from ECU p30
  4. VR-
  5. VR+
  6. IGN Live
  7. VR Wire shield
  8. Coil A
  9. Coil B
  10. Ground (high current)
  11. Coil C
  12. Coil D



Link to comment
Share on other sites

1 hour ago, ThreePointFive said:

Yeah it's in the 150rpm region

That suggests the VR sensor is OK then so that can pretty much be ticked off, it means the EDIS is getting a signal it recognises and can interpret correctly.

Narrows it down to a wiring issue on the EDIS/coils or a faulty EDIS unit. Have you checked the high capacity earth on the EDIS has a decent connection to the engine ? It uses that connection to switch the coils to.

Link to comment
Share on other sites

Hi Dave,

thanks for the pointers - I've been waiting for the other EDIS to turn up before looking at it again but it seems that's not the issue.

When you say high capacity earth, do you mean pin 10?

This might be my problem - mine goes straight to battery.

Link to comment
Share on other sites

Had some 3mm so did exactly that. Wasn't the problem but not surprising.

I now want to pull everything off the car and check it over but as I've soldered things up on both sides of the bulkhead, I would be cutting a lot of wiring to get it out.

I'll keep looking but I am stumped.

Link to comment
Share on other sites

I'll have to get a can as I don't have anything, but the spark indicator thing I bought is saying there's nothing going on.

The mystery isn't solving itself. I plugged the laptop back in to see what it's doing and it looks the same as before any of my changes. I'm still getting the gauges showing activity for the first second or so of cranking and then going back to zero even though it's still cranking. Here's another video to show what I mean.


Is this normal?


Link to comment
Share on other sites

What spark indicator and have you double checked using the old school method with a spark plug resting on the engine block ?

You seem to have an issue with your IAT/MAT which is probably what's causing it to try and fire at TDC... which might be an issue with EDIS ?

Did you try EDIS without the ECU at any point ? 

Link to comment
Share on other sites

At the risk of sounding like a hack, have you tried it with just the EDIS module, wired straight to the battery?

That would give an idea of whether the wiring is at fault on the power side of things.

What was the truck originally, petrol or diesel?

Link to comment
Share on other sites

Looking at the RPM reading I'm suspicious that it's not actually getting a reliable RPM signal, perhaps VR reversed or something - you can get phantom RPM for a second or two just from the voltage spike of cranking and the way TS works - I'd like to see what happens if you crank it for ~5sec, ideally a datalog. The squirt LED on the ECU should flash for the whole 5 seconds if it's getting RPM.

My suspicion (albeit a very shaky one) is that with the VR wires reversed the EDIS puts out an intial RPM reading until it sees the "wrong" double-gap signal that happens with reversed VR and then it shuts down. It's been so long since I've had to mess with this that I'm <50% sure about that behaviour though.

Link to comment
Share on other sites

Bowie, at this stage I'll try anything. Is that pin 6 on the EDIS and the white/purple coil/fuel pump/lamba wire straight to battery then? Are there any others?


Fridge, I can do that. I'll do it with the current orientation and then swap it around so we can see the difference.

Link to comment
Share on other sites

So Fridge wins, but not for straightforward reasons, I'll go through my process so you can see anything I might not realise is significant. Brace yourselves for boredom but I also want to demonstrate just how complex this was and that I wasn't completely being an idiot.

I tried the direct-to-battery EDIS and coil with ECU unplugged method, no change. I switched the VR terminals around while in that configuration, no change.

I put everything back to standard and bolted the ECU to it so I could try Fridge's test of a 10-second crank. First try was as expected, exactly the same behaviour as in the video above.

Second try, I swapped the terminals around and this time the rev counter didn't drop off after a second and I get a big healthy spark against the block. So it's the VR sensor...….clearly?

Apart from one thing - it's now wired up back to front from the diagram. The positive on the EDIS goes to what is meant to be the negative on the VR sensor and vice versa. This is why every time I tested it, the right wire went to the right terminal and checking it against the diagram (4 separate times) I was seeing exactly what I expected. It also means a month ago when I discovered I had wiredit back to front and corrected this (before I tried first crank), I had actually un-corrected it.

What none of this explains is why I didn't get spark when I tried swapping the terminals in the direct to battery setup, or in any of the other times I had switched them. Anyway, I wasn't going to question this so once I got the spark, I tucked away the wires for installing the dash properly as I thought it was all finished. However, at some point between tucking the wiring away and testing one more time, I was not getting spark any longer.

The fact I was suddenly getting spark after plugging the ECU in (moving the wires to do so) and then lost it again when I tucked them back where they were, it had to be a fault with the ECU wiring which I had discounted as I've been told multiple times EDIS works independently of the ECU. 

Immediate suspect was the orange and slate wire that comes from EDIS pin 1 to ECU pin 24. I have a pre-wired D37 plug from Nige as I couldn't solder the pins up myself due to a combined lack of patience and skill. Pin 24 has two (white and earth) wires with shielding on this pre-wired pigtail and it looks like the solder connection had very slightly seeped to make contact with the shielding or the negative, but to the point it only made contact in certain positions. When I pulled the wire straight to connect the ECU, I must have broken that connection. 

Cutting back the shielding and earth further, I taped this up and then soldered the white and orange/slate wire. I have spark again.


I don't know why this would make a difference if the ECU wasn't connected, as surely this would be an incomplete circuit? Either way, now it's working fine.

So I should be ready to go and fill a jerry can with petrol and see if it'll run tomorrow except I found one of my brand new core plugs is weeping, so probably not a great idea to get it hot. I hate Land Rovers.

Edited by ThreePointFive
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy