Jump to content

Recommended Posts

I left the defender (200tdi) running in lockdown for an hour a week to keep the battery topped up .it started to get a bit smelly so took it for a spin and a huge cloud of white smoke bellowed out of the back .it cleared after a mile or so it runs smooth and starts on the button .it hasn't lost any water and burns no oil .there's nothing from the oil filler cap .the turbo is in good shape .has anybody got any ideas ?is it possibly dirty injectors?

Link to post
Share on other sites

Nothing to worry about IMO. Idling it like that never gets it properly hot and I think leaves unburnt fuel. Mine will do the same (especially if i forget theres veg oil in it and leave it idling whilst working round the fields). Take it for a good run and dont worry about it. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy