Jump to content
keeley75

MS2 compatible IAT sensor M10 X1.25

Recommended Posts

Hi all,

 

Does  anyone know of an M10 x 1.25 IAT sensor compatible with MS2.

I’ve got one supplied by Nigel which is M 14 I think. I’m after one that won’t require me to calibrate the new one with buckets of ice and such like.

I’d also like it to have the same connector......

413451D6-8744-4189-ABB5-3ED84B36343A.jpeg.05819913abd58be90804ba9205ca7018.jpeg

 

Thanks in advance...

 

Share this post


Link to post
Share on other sites

The Megasquirt/MSExtra forums might know a few standard part numbers, the MS default sensors are very common GM flavour but ones with matching response curves show up in thousands of makes/models.

Share this post


Link to post
Share on other sites

Thanks Fridge,

I’ve taken the plunge and got one of these

982FEFE5-5628-4E7E-B277-2534FBC7E493.thumb.jpeg.338a2287767c9f09264d653844a989d0.jpeg

Lucas SNB801 used in everything from a metro to a 5.3 V12 Jaguar.

Being Lucas it will be the pinnacle of Automotive electrical Wizardry!!!!

But it’s M10 x 1.25. I’ll update with the results.

 

  • Like 1

Share this post


Link to post
Share on other sites

Lucas IAT arrived today.

F349AA69-9210-4CE4-86DB-6C32B7037E92.jpeg.89e981bf53c1370f4ca58504f5e210ac.jpeg

I went through the instructions for Tunerstudio and got myself a bag of ice, kettle and a meat probe ( thermometer).

I took some readings from the Lucas IAT with the intention of sticking the Resistance vs Temp values into the calibration table.

 

Before doing this though I ran the same tests with the current Unit supplied in Nigel’s Xcess 4x4 kits.

image.thumb.jpeg.6402e23a821bb7dc8e3ee28c16af6401.jpeg
 

BLACK LINE LUCAS

RED LINE Standard Megasquirt IAT.

I was expecting a linear graph. `excuse the secondary school diagram.

If I was to draw a ‘line of best fit‘ (asked the A level Son for its technical name)

Should this be the readings I stick into Tunerstudio ???

If I draw a linear best fit line then I can leave the current settings as is because the current sensor is all over  the place and would be pretty similar plot

So I think it’s close enough.. It was 20 deg Celsius ambient today. Measured via the thermometer. Both the Lucas IAT And the Nige supplied IAT registered 20 deg Celsius in Tunerstudio.
 

So I think it’s a pretty good match. Unless I’m simplifying things and Megasquirt is a bit more sensitive or precise than I’m assuming.

Any thoughts welcome !!!!.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

I suspect the graph shape is as much down to DIY measurement inaccuracies as anything - IAT sensors are not sealed so dipping it in water or getting it steamed up are going to conduct electricity and skew your readings. Coolant temp sensors are closed-end for this reason.

Here's the basics on sensor values:

https://www.ametherm.com/thermistor/ntc-thermistor-beta

The graph should typically be a curve, which yours is if you squint hard enough... I might even suggest you've lucked out and found a sensor with the same curve, given that the default is a very popular type.

You enter the values in TS here (after unlocking) although it looks like you may not need to.

therm.png.660cf11988325147b40415a2669dcf8c.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy