Jump to content

Recommended Posts

I am putting my 110 CSW together and want to ask where do I connect the towbar wiring loom to the main loom. In the space up in the rear station wagon body or in the wheel well behind where the rubber divider goes? I will post pictures tomorrow when at the barn.

Link to post
Share on other sites

Got the two looms through their holes. Towbar loom to the left and main loom to the right. In the process of slowly matching wire colours. Still to put the grommet back in the hole to the right. It seems I have miss placed some double connectors so also need to get them.

16036395459118917235153346768883.jpg

Link to post
Share on other sites

Thanks for all the replies. I have a Euro 12 volt plug and cigar lighter in each rear body lamp covers which I want to keep. Not sure if I could fit those connectors behind the lamp covers.

20201025_142100.jpg

Link to post
Share on other sites

Holy bobbins, the difference between your interior and mine :hysterical:

I can't decide if you're putting me to shame or you're just not using yours properly :P

One of these days I'll go round with the rollers and re-paint mine, might even wash it first...

Link to post
Share on other sites

Thanks Fridge Freezer for the compliment. It has been a 8 year long job so far. I am an accountant who is learning to be a mechanic on the job. I have used her properly, if one could say that, in overlanding from Somerset down to Cape Town in her 2013. 

  • Like 1
Link to post
Share on other sites

Ah, got it now you've done the Somerset to Cape Town trip in 2003 & now your doing the restoration. I thought you were going to do that trip once the restoration was completed

Link to post
Share on other sites

FF, your Maypole connector box looks incredible, but, I visited their site and they give absolutely zero data on the internals of the box.  Did the internals shown in your third photo all come as an integral part of the box, excluding the wiring, of course?  On their site I couldn't even see a "Contact us" link.  They really do need to get a decent web designer, or get me a new pair of specs!

Mike

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy