Jump to content

Coding of injectors - Not necessarily LR related


Recommended Posts

Apologies that this isn't LR related but my question is about Bosch common rail diesel injectors, fitted to a Honda 2.2 CDTi engine. I am replacing them as part of a cam chain and oil chain overhaul.

The question is about coding. Whilst I have a cheapo code reader, I don't have the HDS software but hope I can get the codes written at a local garage.

I believe that the codes are used to compensate for manufacturing tolerances and thus used to inform the ECU of the specific operating characteristics of a particular injector. From that I'm hoping that by not updating the codes until the vehicle can be driven, I am only losing a small amount of performance rather than risking some major malfunction.

Can I install the new injectors and then expect the engine to fire and then drive somewhere to get the codes updated? Will this cause any problems or am I correct and they are used for fine tuning and so aren't essential immediately?

I trust this forum far more than anywhere else, hence asking here first rather than in a Honda specific place.

Thanks

 

Link to post
Share on other sites
8 hours ago, Peaklander said:

Can I install the new injectors and then expect the engine to fire and then drive somewhere to get the codes updated? Will this cause any problems or am I correct and they are used for fine tuning and so aren't essential immediately?

 

Whilst I am not familiar with the Honda in question, from a Td5 owner's point of view, the engine will start and run quite fine with incorrectly coded injectors, the coding is as you say, for fine tuning.

When I replaced my head, I discovered the injectors fitted were not even listed in the ECU, let alone in order, and it ran fine, blown head gasket notwithstanding...

  • Like 1
Link to post
Share on other sites

Thanks guys. That makes me feel better. These fancy injectors are way outside my knowledge. The job so far has been a pig to do. The cam cover won't come off without the injectors out. There's no wiggle room because of the shape - they can only come up. Two loosened with the engine running and the clamps slackned but two were stuck. I approached ten local-ish garages and one had a slide hammer and was willing to lend it and they popped up with very little effort.

The crank pulley bolt needed to be cracked using the starter and a breaker bar. I broke the first bar at the knuckle with muscle power alone. The sump will only come out if the subframe is lowered slightly. Oh for a simpler 300TDi...

Link to post
Share on other sites

How old is the Honda ?

I run old Vauxhalls, and I have done this without problem. These can have a choice of injectors, but if the numbers on the injectors are all the same (a set)and are the same as the originals, you shouldnt have a problem.

Im not 100% on this, but I thought this coding was only for later piezo injectors.

  • Like 1
Link to post
Share on other sites

Its a 58 plate (262K miles). Bought as a budget car 😀.

They are identical injectors with the same part number but the reconditioned Bosch ones are provided with the codes, each one has a tag.

Bosch refer to them as IMA codes. 

Edited by Peaklander
Added IMA
Link to post
Share on other sites

It'll run, sure - but with the injector-profiling unmatched to the original ECU fuelling-profile it will be less-than-optimally-efficient, less-smooth-than-it-could-be, and potentially wasting fuel and giving the catalytic-converter/emissions-control-system a hard time with over/underfuelling.

Why do half-a-job when you could get the thing properly matched?

Link to post
Share on other sites
On 12/24/2020 at 6:15 PM, Tanuki said:

Why do half-a-job when you could get the thing properly matched?

He's not, he's saying he'll have them coded in at a garage when he can get it there. 

As for what difference it makes.... certainly on the Td5 they'll run happily without being coded and I bet 99% of people couldn't actually tell the difference in how its running. They're precision things, so the tiniest differences in manufacturing tolerances are going to be minuscule. 

  • Like 1
Link to post
Share on other sites

It’s only been in our family for a few weeks. I said it would be a good bet as I have confidence in Hondas but still a gamble.

I have got as far as removing the timing case (so a long way) and can now see the cam chain and associated parts.

Some of the (many) fixings to be removed have been very difficult so say the least but they are off!

Currently trying to see what's actually wrong. The tensioner appears to jump back to ‘no tension’ as the crank is turned.

Don’t know how much to post as this isn’t really the right forum  😁

Edit: here goes... chain noise in running engine

and ... chain and tensioner 'in action'

 

Edited by Peaklander
Added links
Link to post
Share on other sites
  • 2 weeks later...

This is the comparison between the old and new cam chains. Not only is the chain about a whole link longer (around the loop), it has some very loose pins but not all of them are loose. It's a little strange tbh as I would have assumed they all wear in the same way.

This is a 'DID' brand chain which I think is original equipment but the cam guides have certainly been changed since the car was built (2008) as the die stamps are 2013 and 2014. I can only assume that the chain was also changed then but that implies that the chain has stretched in about six years.

The much shorter oil pump chain hasn't stretched at all (also 'DID') but I have changed it, along with the guides and the tensioner.

IMG_2704.thumb.JPG.34789e609ae9023b119549163e37c9f7.JPG

 

I have been busy cleaning the injector bores with carb cleaner and rags wrapped around a suitable tool. They have a hard coating of carbon on much of the lower part.

The whole job is suffering from specification creep as I am now looking at the intercooler and probably the turbo. One thing is it makes me yearn for my 300TDi. That is a whole lot easier to access and work on. Removing the sump and timing case on this CR-V requires two engine mounts to be removed, an engine crane, the sub frame to be partially lowered and even then two pairs of eyes and hands.

 

Link to post
Share on other sites
13 minutes ago, Peaklander said:

It's a little strange tbh as I would have assumed they all wear in the same way.

I wonder whether it's something to do with the fact that an engine will almost always stop in one of a few positions so naturally the cam chain would as well. Perhaps that's enough to stretch particular links because they'll be the ones taking most of the load when it starts back up again.

Link to post
Share on other sites
  • 3 weeks later...

The CR-V is almost back together now after a few weeks of turmoil. How different it is working on an engine that sits fairly tight in the engine bay. As well as replacing the cam and oil pump chains, I managed to remove the turbo and stripped it down in order to clean the VNT mechanism which was coked-up and there had been a turbo over-boost fault the last time the car was driven.

Along the way I lost a turbo nut into the exhaust and it rattled its way along to the front end of the cat as I tried to work out where it was. I had to cut-off the cat in order to tip it back out. I also had two M10x50 bolts left over. They were probably the only ones not labelled and it took hours of looking and thinking, before an extended session (at 1:30am) in front of a parts diagram indicated where they should have gone. Luckily there was only the intercooler to turbo pipe to move to fit them.

Generally I found things very hard work. The engine had to be lifted up and down to get stuff in and out. The sump is only removed with the front subframe lowered a few cm. The turbo will only come out with the engine in place (and lifted up and down) if all the stuff over the gearbox is removed, so that's battery and (rusted-on) box, gearshift cables, air box and pipes, fuel pipes, etc. etc.

I'll be glad to get back to my 110.

41BEE4DE-D6AF-41DD-9CF1-FC739AF83AEE.thumb.jpeg.585463482fa8160623ee080824e89fe0.jpeg

94CAB035-50C5-420B-9074-6B80C89DB148.thumb.jpeg.643312cc4e1ba645dfe577d70878c3a2.jpeg

5CA3AB02-A175-4CAD-B683-3215C14011C0.thumb.jpeg.f4ed1e883c2956f24dc02dbff42198b3.jpeg

 

The new injectors haven't yet been coded to the ecu but starting was no problem.

037DCD27-5508-4447-AAF8-90A2D410BAA7_1_201_a.thumb.jpeg.dcff1c6ceb861fee684e0441eb065c7d.jpeg

18169B87-6064-4043-BA45-3F5EBA803F0B_1_201_a.thumb.jpeg.32c7ced8a9433bb52d15de6e7df64f1b.jpeg

 

The first video is the engine running before I started the job. 

The second is the start after the injectors were plugged into the loom after a few cranks on the starter to get diesel up and hopefully some oil into the turbo.

Compare and contrast 😁

 

 

 

 

 

Link to post
Share on other sites

Good job! Working on other vehicles reminds you just how easy it is to work on a 200/300tdi in comparison. Space to get to things is a nightmare on all of the modern Land Rover stuff 

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy