Jump to content

Freelander 1 TD4 low coolant heat. Checking diagnosis.


gadget
 Share

Recommended Posts

With the restrictions slowly being lifted the need for a road legal car is nigh.
I've finished off the necessary jobs and have a new MOT. Took it out for a shake down and all is well except things are not as warm as they should be.

I'm pretty sure I need to replace the thermostat on our 2005 TD4, but want to run the symptoms past y'all before I commit.

The temperature gauge barely reaches 1/4 travel, even after a decent run.
Heater is blowing warm-ish air, but might as well not be doing anything.
Coolant is new and has been bled.

Running the engine from cold the top radiator hose is the first to show signs of heat.
The reservoir starts to get warm via a small flow from the tiny feed pipe.
VERY slowly the radiator starts to warm from top down.
After 20 ish minutes I can detect heat in the lower radiator hose.
During the warm up the heater matrix in and out pipes warm at roughly the same level.

Switch on the blower with heat set to full drops the temperature gauge pretty quickly.


Thermostat or something else?

Link to comment
Share on other sites

Did another 25 mile round trip with spirited driving and I'd estimate the top hose temperature to be around the 38-40C area. Temperature needle still reading about a quarter of it's range. The coolant system isn't hot enough to pressurise, pipes are still easily squashed.

8 hours ago, FridgeFreezer said:

TBH that sounds almost normal for a TD4, mine took about 15 minutes at motorway speed to start blowing warm out of the heater when the FBH wasn't working.

I didn't drive our other Freelander that often, but I don't recall being able to drop the engine temperature by turning cabin heat on full. This more than anything else makes me think it's broken.

 

Link to comment
Share on other sites

  • 1 month later...

Finally got to replacing the thermostat on the TD4. Not the most fun job I've undertaken.

Engine comes up to temp quickly now and the heater is toasty.

Picked up the replacement from island-4x4.co.uk and paid for the "genuine" PEL100570LG part.

The "genuine" part arrived in an allmakes pr2 box and has no markings other than the 88C. Make your own mind up as to genuineness if you're looking for one.

td4.thermostats.thumb.jpg.be6246be630ce706311b6cb21033ea8d.jpg

 

 

  • Sad 1
Link to comment
Share on other sites

I did consider sending it back, but...

I'd already started taking things apart and didn't want to leave things drained for too long.

There are no markings or part numbers stamped into the plastic housing either. I won't be paying extra for a "genuine" part next time if I can't identify the maker.

Edited by gadget
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy