Jump to content

Help needed from Electronic Guru's


Recommended Posts

I bought a smashed RR Sport TDV8 2007 with no keys and a 2008 with no engine and have set about putting the two together by basically rebuilding the smashed one as it is low mileage.

I took the Body Control Unit, the engine ECU, the ignition switch with the receiver collar and the Instrument cluster and have just moved them across. An awful job but took less time that I initally thought. Reconnected the battery and then tried to fire it up. Nothing the power is there but the dash board will not light up and no error messages. I then plugged in my code reader however it will not make the connection when the ignition is in position 2 the code reader is switching on and off in a cycling motion.

First question is are there any other electronic components that I need to shift over and is there a component that needs to be replaced because of the impact?

Link to comment
Share on other sites

or the battery had no charge......DOH!!! 

Started off the key and died. Tried to restart wouldn't go. Left it a couple of minutes fired and ticked over nicely but now have an abundace of faults that I need to clear starting with the suspension and the gearbox. Suspect I need to change the gearbox ecu's and certainly the suspension one. But none of that matters because I have a running TDV8 which is as sweet as a nut and should have most parts available to sort the problems out.

  • Like 4
Link to comment
Share on other sites

On 5/2/2021 at 7:52 PM, Simon_CSK said:

It still doesn't go into gear so may need to change the gearbox ECU. Thoughts appreciated.

Do you mean you can't select a gear? That could be the interlock, a simple solenoid preventing you from moving the gear lever.

Or can you chose a gear, but nothing seems to happen? That could be due to low oil or other mechanical problems.

Great to hear you already have it running! 🙂

  • Like 1
Link to comment
Share on other sites

56 minutes ago, Escape said:

Do you mean you can't select a gear? That could be the interlock, a simple solenoid preventing you from moving the gear lever.

Or can you chose a gear, but nothing seems to happen? That could be due to low oil or other mechanical problems.

Great to hear you already have it running! 🙂

Filip

The car was in a front end bump and the oil cooler was caved in. I suspect that there is limited oil in the gearbox and therefore that is my next challenge with it when I get time.

Link to comment
Share on other sites

3 minutes ago, Simon_CSK said:

Filip

The car was in a front end bump and the oil cooler was caved in. I suspect that there is limited oil in the gearbox and therefore that is my next challenge with it when I get time.

Ah, is the lever moving into gear then? It won't let you take it out of park without the solenoid activated. 

Link to comment
Share on other sites

2 hours ago, landroversforever said:

Ah, is the lever moving into gear then? It won't let you take it out of park without the solenoid activated. 

With the engine running I can move the gear lever yes.

  • Like 1
Link to comment
Share on other sites

The engine would have been running with the rads impacted on the viscous coupling. That would have pumped some oil out at least and then with the radiator leaking certainly any oil in the radiator would have bled out. I haven't seen any evidence of any fluids when replacing radiators which gives me more confirmation of my theory.

  • Like 2
Link to comment
Share on other sites

12 hours ago, Escape said:

Should be an easy fix!

Started it 5 minutes ago after filling the coolant this afternoon. Suspension raised to full height and manged to reverse it about 6 inches. Couldn't reverse any further as it is on my trailer and the steering wheel is not fitted so should be able to reassemble the front end i.e. bumper and intercooler scoop before doing the airbags. Making good progress will soon be ready for painting.

  • Like 4
Link to comment
Share on other sites

On 5/5/2021 at 7:49 PM, Simon_CSK said:

 Making good progress will soon be ready for painting.

Simon, you are you using for painting? I have the 90 rebuilt on galv chassis and and getting bodywork ready to paint, but have been let down by a painter - who are you using locally? (feel free to PM me rather than post)

Greg

Link to comment
Share on other sites

1 hour ago, Mean Green said:

Simon, you are you using for painting? I have the 90 rebuilt on galv chassis and and getting bodywork ready to paint, but have been let down by a painter - who are you using locally? (feel free to PM me rather than post)

Greg

PM'd

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy