Jump to content

Help with my disco 2 v8


remi
 Share

Recommended Posts

Posted (edited)

Hello everybody.

I'm driving a discovery 2 V8 ans I have a lot of problems.

Now when I'm driving around 1500/2000 rpm,suddenly the engine rpm drop to 1000 and then come back to normal.

Or I feel like a "push" or shocks when I'm driving

Also it has less power and one time i heard a bang i think it was coming from the exhaust. 

I've put new spark plugs but I still have those problems.

I don't know if I have to look at the ignition or the injector.

Please if someone can help me

 

Tks everybody

Edited by remi
Link to comment
Share on other sites

  • remi changed the title to Help with my disco 2 v8
Posted (edited)

The battery is new as well.

It only backfired once.

Otherwise Rpm goes down suddenly and i feel like push or shock like misfire and no power even with My foot all the way down hard to pass 1200 rpm sometimes

Witch earth connection should I look at ?

Edited by remi
Link to comment
Share on other sites

I'd check the main battery connections; battery to engine/starter and battery -ve to chassis & engine block. If yours has a distributor then the ignition amplifier module on the side loves to go faulty - usually they either fail as they get warm or fail once they cool down.

 

Link to comment
Share on other sites

Thanks for the reply.

I've 2 ignition modules behind the engine.

Sadly I'm living in the middle of nowhere and I can't find someone to do a diagnostic on my engine.

I was thinking about replacing those 2 ignition modules.

Yestersay I've checked all the plug wires and they all look fine.

I will check all ground cable today. I'll let you know if I can find the problem

Link to comment
Share on other sites

On 5/21/2021 at 6:56 AM, remi said:

Hello everybody.

I'm driving a discovery 2 V8 ans I have a lot of problems.

Now when I'm driving around 1500/2000 rpm,suddenly the engine rpm drop to 1000 and then come back to normal.

Or I feel like a "push" or shocks when I'm driving

Also it has less power and one time i heard a bang i think it was coming from the exhaust. 

I've put new spark plugs but I still have those problems.

I don't know if I have to look at the ignition or the injector.

Please if someone can help me

 

Tks everybody

As the engine has full electronic management system  and even linked to the auto gear box if fitted, the  needs to be plug into a diagnostic test kit to give u an idea of what is what. Iffy o2 sensor are notorious for issues, the same as the other sensors for that matter.

Link to comment
Share on other sites

They can easily contribute to an engine misfire, such as misinformation to the management system on the air fuel ratio as an example.

 

Link to comment
Share on other sites

3 hours ago, teabag said:

They can easily contribute to an engine misfire, such as misinformation to the management system on the air fuel ratio as an example.

The reverse is also true - a misfire throws the O2 reading off because one or more cylinders is throwing unburnt fuel down the exhaust and can even coat the O2 sensor element, which throws it totally out of whack.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy