Jump to content

Suspension,tire


Recommended Posts

On my 89' 90. I changed all of my bushings to comfort poly's. Fitted on Iron man suspension which is claimed 2 be a 2 inch lift. Slapped on new alloys mounted with BFGoodrich 295/75/16 AT. Which fills the wheel well perfectly in terms of dimensional looks on the vehicle. Just looks really great but i cant understand why when going around the windy roads of Jamaica at a good incline it rubs in the back. the supension is very firm. 2 stiff i feel as this car is my daily driver and its brutal on the potholes. Could I have something somewhere not tightened enough. I am not sure but I am at a time when the engine is being overhauled and gear box mounts being changed so if I am gonna make a body lift i will be doing it now. Still contemplating. but still not seeing why it should be rubbing. My lock barely barely rubs "not a big deal at all". SOMEONE HELP ME SOLVE THIS PLEASE WITH OUT THE LIFT. Thank you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy