Jump to content

300Tdi thermostat


mmgemini
 Share

Recommended Posts

My daughter broke down last week with overheating problems. Luckily this time she was looking at the temperature gauge.

Les agreed with me "thermostat"

Here are the pictures.

Comments please.

img3070dl0.jpg

img3072wf6.jpg

The car is a 300Tdi Discovery. This thermostat was fitted November 2005 and the car is used daily 50 miles each way to and from work.

Yep it's a Genuine Land Rover one made by Waxstat.

mike FOAK

I can cause trouble in an empty house !!

I don't bother getting the tee shirt

Link to comment
Share on other sites

looks like the shaft was bent during fitting, never seen one go like that due to excessive heat from the engine.

It was fitted by a very competant fitter xxx thousand miles ago and 18 months it has run a long time without any problems - so why has it just done it this week?

Mike

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy