Jump to content

Judder under load


discosi
 Share

Recommended Posts

Help/guidance wanted.

I have a 1996 disco, 300tdi, and have suddenly started getting a 'judder' through the vehicle when accelerating. It appears to be intermittent possibly when loading the engine. It proves difficult to pin point but seems fine on initial acceleration and when up to speed but inbetween the 'jubber' starts. The engine seems to be running fine when standing and when increasing the revs, but does seem to be hot (could only just hold onto dip stick as so hot after 2 hour drive) , although the temp gauge does not show it.

Any advice as to where to start to look would be much appreciated. steering, wheel bearings, prop shafts? etc.

Cheers

Link to comment
Share on other sites

Any advice as to where to start to look would be much appreciated. steering, wheel bearings, prop shafts? etc.

my moneys on a front prop JU....

to check the front UJ's jack up a front wheel and rotate the prop looking for play in the joints.

Link to comment
Share on other sites

my moneys on a front prop JU....

to check the front UJ's jack up a front wheel and rotate the prop looking for play in the joints.

Thanks for the guide. Have found rear UJ on front prop shot. In process of replacing.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy