Jump to content

nas miss-fire fixed


nas90
 Share

Recommended Posts

Have had a few problems recently with the nas including having to replace all the petrol injectors and the lpg wiring harness. The Italian lpg harness clips into the petrol injector harness to shut-off the petrol side of things when running lpg. However, the LR harness is as good as the day it was made but the Italians left a gap down the outer sheath, water and mud then made it's way to the petrol injector and rotted the contacts. So having found and tested 8 good secondhand injectors and got a new foc harness and made it water proof the nas was still miss-firing. With both Diesel Dave and Angus using their marvellous bits of electronic wizardry there was no miss-fire but when the engine revs were increased sounded like a traction engine.

Much head scratching pointed to the TC flex plate and today the auto box and transfer box were dropped and guess how many pieces the flex plate had become :o

So off to Harwoods tomorrow to get a new flex plate and then all will be well :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy