Jump to content

Elec issues and need advice.


simon15
 Share

Recommended Posts

Just fitted a decent battery to my disco courtesy of Dilligaf a big thank you.

I now have power and it starts fine but when i turn the ignition on the battery light is not illuminated,

And i also have no rev counter only now and again when it feels like it,

And lastly the battery light comes on bright as soon as it hits 3000rpm.......

is it a new alternator or something else...

Need to know asap as i need it fixed for the navigation outing this weekend.........

Link to comment
Share on other sites

Check the connections on the back of the alternator, sounds like something is amiss with the alternator. also check the voltage at the battery as it should be up around 13v if the alternator is working

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy