Jump to content

P38 Starting Problems 3.9 GEMS


Chris Croot
 Share

Recommended Posts

Have been having starting problems with my 1998 GEMS V8 3.9l petrol RR which has been LPG converted.

I have a problem that when you turn the key to start, 7 times out of 10 it will start without any problems at all. The other 3 it will just crank the engine but never start. It doesn't appear to fire. If you then turn the key to off, wait 15 seconds and re try it will generally start. Sometime you have to wait another 15 seconds but generally it starts on the 2nd go. Any shorter than 15 seconds then it will still be in the problem state. You can guarentee to get it into the problem state by turning the engine off after it has been running sucessfully and then immediately try to restart.

Diagnostics done (while in problem mode)

Plugs are sparking correctly, fuel pressure on rail is good. Crankshaft & camshaft sensor output scoped at ECU plugs are fine.

Scoping out the injector pins on the GEMS ECU it appears that the ECU isn't signalling the injectors to open.

Mass air flow connectors and output have been checked and are ok.

I have tried a replacement GEMS ECU, replaced the power board in the bECM and tried a new gas ECU, all without any joy.

The gas system has effectively been taken out of the loop and the problem still occurs, so it does not appear to be a gas system problem.

No problems show on the gas diagnostics and no errors logged on the RR ECUs when looking with testbook.

One of the garages that looked at it for me said that if they manually injected fuel when it is in the non working state, it would start

and the ECU will start to tell the injectors to work.

Anyone got any ideas on what I could look at next as I am now completely out of ideas!

Regards,

Chris.

Link to comment
Share on other sites

Have found what the problem was while re-checking the sensor inputs on the ECU.

The throttle position sensor was consistently outputting 4.7V no matter what position.

Have disconnected the multiplug on the sensor and vehicle now starts everytime. New

part ordered and will be fitted when it is received. Can anyone explain why the TPS

reading the value as if it was fully open would stop the injectors from opening.

Of course in the time honoured Range Rover fashion, I am now suffering another problem!

Will start a new thread for it!

Regards,

Chris.

Link to comment
Share on other sites

  • 4 months later...
The ECU has an anti-flood strategy.

In the event of you applying full throttle while cranking, it switches off the injectors.

(To prevent flooding of the engine with petrol).

Correct, I spoke to a friend who worked on the management system. Pity the LR dealer

I had look at the vehicle didn't know so would correctly diagnosed a failed throttle position

sensor which had failed showing a full throttle position.

Regards,

Chris.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy