Jump to content

Window wiper problem


Recommended Posts

Well after i replaced my bulkhead and puting every thing back together i seem to only have one speed on my windowwiper's. That speed is the second up click(the fast one) but dosnt nothing when up one click or down.

Anyone had this problem and know how to fix it ? all the wireing hasnt been touched.

Link to comment
Share on other sites

Well after i replaced my bulkhead and puting every thing back together i seem to only have one speed on my windowwiper's. That speed is the second up click(the fast one) but dosnt nothing when up one click or down.

Anyone had this problem and know how to fix it ? all the wireing hasnt been touched.

Probably the park switch has broken as they're quite fragile - its on the passenger side just up inside the dash - you'll need to take the end panel of the dash off to get to it. Little white thing IIRC. Very easy to replace - takes longer to get to it and replace dash bits. Think it cost about £10 but may be mistaken - should be available from any Landie place.

Failing that the switch at the steering column end?

Link to comment
Share on other sites

  • 3 weeks later...

ok little up date i replaced the park switch sensor but still nothing. So i started testing the wire's and it seems to be sending the right voltage at the right time but its not working maby i have a wire in the wrong place or something so could anyone do me a big favor and take a pic of there wiper motor please.

Or maby someone has a wiring diagram or anything they could give me.

Link to comment
Share on other sites

all the wiring connectors are in plug/sockets, so there should be no way to get the connections wrong as the plugs/sockets will only fit in one way, most likely the column switch is duff & is the earth lead reattached to the bulkhead at the wiper motor clamp top screw.

Link to comment
Share on other sites

wiper motor earth is on a single wire with a female spade on it, the tag should be at the motor top clamp bolt, it should be a ring terminal with a male spade tag on it, the wire is part of the wiper motor wiring & comes off the motors multiplug.

Link to comment
Share on other sites

Taken dash apart but there is no sign of a earth is there anyway i can sort this?

in the wiper motors plug that fits into the motor socket, find the black [earth] & join a extra lenght of wire preferably the same size/colour to it before the existing one goes into the plug, a 4 way bullet connector or piggyback spade connector will do, then fit a ring connector to the other end & put this under the brackets upper screw head, job done.

Link to comment
Share on other sites

Waiting here with baited breath since my Disco has similar problem (only works on slow speed and with water jets and no self park). One thing I noticed now is that occaisionally the wipers come on by themselves when using the winch! This must sure point to a wiring/earth problem rather than switch? I changed motor out and the column switch out with no difference at all.

Link to comment
Share on other sites

ok earth is put in but still no play but i do hear a little sound from the fuse box when i try it. also it only works in 2nd speed and nothing else so maby its the bit near the stearing wheel ?

the sound from the fusebox area could be the intermittent wash/wipe relay trying to operate, take the fusebox cover off & pull back the matting up each side, you'll see a crosshead screw each side take these out & release the fusebox from the bulkhead, the intermittent relay is red & mounted on the bulkhead sise of the fusebox, try a known good one & see what happens. if it sill doesn't work it must be a duff wiper stalk.

Link to comment
Share on other sites

  • 2 weeks later...

I have finally had some time to look at it and i think the problem is with the 3 wires(Blue Red Yellow) after the park switch would anyone have a pic or know witch way these go.

EDIT: ok had a look on net and found out what ways the wires goes no i have all speeds apart from the fastest :S gtg to work now so will have a closer look tomorow

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy