Jump to content



Recommended Posts

I obviously spoke too soon when I said the 90 is running beautifully at the moment :angry:

Went to sainsburys earlier and it was running fine, came out and it started fine, but on leaving it started to stutter as you accelerate, to the point of sometimes stalling when you give it full throttle.

This has happened before so I managed to nurse it home by using full revs and slipping the clutch to get it moving and then using the choke to stop it faltering, thinking that if I left it for a while outside the house it would sort itself out. Left it for an hour or so and tried again, no change whatsoever, it still runs perfectly at idle, but anything above that has it stuttering :angry:

All I've done this morning was top up the oil, and the only other thing I can think of is that it's quite low on fuel.

Any ideas what might cause this?


Link to comment
Share on other sites

Hi Richard, there are a number of possibilities, but the most likely is dirt in the carb which blocks the main jet on accelerating. If it does not falter immediately you accelerate, but shortly after, then the in tank electric fuel pump may not be pumping its full amount due to fault or blockage. Similarly the fuel filter may be blocked, causing a slowing of flow necessary for load. Note that the paper filter can look clean but be restricting flow if there is some water in the fuel which soaks into the paper. The water molecules are thicker than the fuel so can be trapped in the filter and prevent full fuel flow. Keep your eyes peeled for water globules in the filter bowl.

Other possibilities include a perforated accellerator pump diaphragm on the passenger side of the carb(under square cover held on by 4 screws)

Check for vacuum leaks and check that if you pull the carb to dizzy vac pipe off at the carb, you can suck on it and feel resistance. You chould not be able to suck air.

The fact that pulling the choke out works to keep it going, implies that there is dirt in the carb.

Hope this helps,



Link to comment
Share on other sites

according to the workshop Manual:

Engine Misfires on Acceleration:

1. distributor points incorrectly set

2. faulty coil/condenser

3. faulty sparking plug/s

4. faulty carburettor

5. vacuum pipes disconnected at inlet manifold.

sounds as though it could well be the carburettor to me, is it called the acceleration pump that occasionally gives difficulty? Not that I've ever repaired one, I have read up on it though, in French! :)

Link to comment
Share on other sites


I have had similar things happening loads of times in the past on our three (one now sold) 2.5P vehicles, the 90 I used to run and the 90 & 110 on Dad's farm, and in every case it was sh** in the carb/fuel system and a good clean out solved it temporarily. It drove me up the wall and was one reason I eventually sold the 90 I used and got a Tdi because it seemed to last about 2-3 months at most and then mysteriously got muck in it and started playing up - but on my 90 the fuel filter was rarely dirty, the tank was drained more times than I care to remember and it was always filled with clean fuel from the pumps. I think it must have been the fuel lines breaking up inside or something like that - never got to the bottom of it all I knew was that dismantling and cleaning out the carb seemed to cure it for a while. It was often as you describe, idle was fine but any amount of throttle and it spluttered and died.

One trip I did once I drove the damn thing about 10 miles home (off road) and it would only run at all by pumping the throttle frantically because the main jets in the carb were completely blocked and the only fuel going in was from the "accelerator pump" in the carb so every pump of the pedal you got some fuel, then it died again. Made for "rather jerky" progress but I got home in the end - probably knocked about 10 years off the life of the transmission though!

Have you changed the fuel filter? restricted flow through the filter can cause problems like this if it is completely blocked up with gunge. We used to have this problem on the farm vehicles when filling out of 205L drums, because a lot of the drums had water and muck in the bottom and the silly little filter element on a 2.5P only takes about an eggcupful of muck to block it up....

Something else I would check - does yours have a "vapour seperator" this is a metal can screwed on the bulkhead at the back of the engine bay? - two fuel pipes going in the top (feed and return to tank) and one out the bottom which goes to the carb? If so take this off and blow it out with compressed air - one problem I had on one of the farm ones at one stage was paint coming off the inside of this unit and blocking the outlet hole in the bottom - giving fuel starvation. At least I think it was paint - I took it off and it rattled inside, whatever it was wouldn't come out, so I banged it on the bench a few times in a rage, blew 150psi through it and whatever was inside shot out through one of the pipes, bounced off the garage wall 20 feet away and I never saw it again. The vehicle ran fine when I put the separator back on :D

Once you have checked the separator I would also take the fuel line into the carb off, blow that out, and check the very fine gauze filter which is inside the pipe fitting where the fuel line feeds into the carb. I think you undo the fitting and take it out and the filter mesh is inside - I have also had problems with that blocking up in the past.

Other than that I suggest you buy the Haynes manual on Weber carbs and enjoy your weekend wondering which jet was which - I can vouch for the endless fun of stripping these units having done it far too many times :D

Link to comment
Share on other sites

Cheers guys, I thought it would probably be the carb but thought I'd ask for any other suggestions as I needed it working tomorrow and didn't want to be looking for other things to try at the last minute!

Started it this morning and it still wasn't running properly, so I took the top off the carb and sprayed some carb cleaner in there and it cleared it almost straight away. Don't know what was in there, but it's running nicely again now :D

Thanks for the suggestions,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy