Jump to content

electris spoil fun


grk
 Share

Recommended Posts

I very much need help:

I have a 1992 range rover classic form Qatar fitted with an 4.6l engine. The car is in good shape (rust free) and has low km’s. However electrical failure is spoiling my fun for months .

I lost my rear screen heater, rear screen wiper and interior heater at the same time. Later my electrical mirrors refused to move down wards Now: I replaced my alternator because my battery light was coming on intermittently and the tach was jumping around. The new alternator (120amps) is charging but still causes irregular coming up of the battery light and the tach is dead.

Any fuse I could find seems ok, the fusible links seem ok,

What next to do? Could it be the multi functional unit? Could it be a faulty ground or cable brake? Does anyone has experienced this? Where do I look in my car? Could there be a shared defect? I have wiring diagrams in the workshop manual find them hard to understand

Thanks a lot

Rogier, Netherlands :unsure:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy