Jump to content

D1 V8 EFI engine issues

Recommended Posts

Just I quick question. I earlier tried a different ECU and after about 10 min the check engine lamp went on. It was ECU for a RRC. Is it possible that the ECU is telling me that there is someting wrong?

Share this post

Link to post
Share on other sites

Update: It now seems that the car is running ok again. It turns out that original Lucas coils can't tackle the Mallory dizzy, so we tried a different coil. That helped and it now runs pretty smooth :)

So I've now ordered a new Mallory coil. I'm pretty happy.. :rolleyes:

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy