Jump to content
haakon

D1 V8 EFI engine issues

Recommended Posts

Just I quick question. I earlier tried a different ECU and after about 10 min the check engine lamp went on. It was ECU for a RRC. Is it possible that the ECU is telling me that there is someting wrong?

Share this post


Link to post
Share on other sites

Update: It now seems that the car is running ok again. It turns out that original Lucas coils can't tackle the Mallory dizzy, so we tried a different coil. That helped and it now runs pretty smooth :)

So I've now ordered a new Mallory coil. I'm pretty happy.. :rolleyes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy