Jump to content

New 200 & 300tdi owners


JJ7893
 Share

Recommended Posts

Hi there, Mine name is John Jones better known as JJ :rolleyes: , I have received a 200tdi and a 300tdi Discovery for nothing on Freecycle :P both need a fair amount of work 200tdi needs welding and a very small job on the gearbox :blink: , the 300tdi needs wheels (but hoping to sort that out later with the old owner) and a couple of mechanical jobs on the engine & front axle :unsure: . I hope that this forum will help me and my partner (Who is having the 300tdi) to be a better and a happy owners :rolleyes: and I hope to return the favor back to your forum soon,

Forgot to say great site you have too very informative and friendly too :rolleyes: . Plus this is the first time I have owned a landy even though I have worked on them for a while now lol.

Regards JJ

Link to comment
Share on other sites

Hi there, Mine name is John Jones better known as JJ :rolleyes: , I have received a 200tdi and a 300tdi Discovery for nothing on Freecycle :P both need a fair amount of work 200tdi needs welding and a very small job on the gearbox :blink: , the 300tdi needs wheels (but hoping to sort that out later with the old owner) and a couple of mechanical jobs on the engine & front axle :unsure: . I hope that this forum will help me and my partner (Who is having the 300tdi) to be a better and a happy owners :rolleyes: and I hope to return the favor back to your forum soon,

Forgot to say great site you have too very informative and friendly too :rolleyes: . Plus this is the first time I have owned a landy even though I have worked on them for a while now lol.

Regards JJ

Prynhawn da, JJ, Croeso.

Link to comment
Share on other sites

Forgot to add do anyone perfer 200 or 300 tdi? My 200tdi needs welding as stated above, but the rear box part on the body not chassis need replacing and I seen 1 on e bay but at £130! Can I get 1 cheaper? If so do you know where from please, I would plate it but it already been plated and underside is not there just a pair of body mounts :blink:

The 300tdi is not running well it only starts with a bump, and there no power when you press the pedal, From what I have been reading on your forum, it mostly states the fuel lift is at fault. Do you still think that is right? The last owner was told it could be the relay? What do you think to that?

Also there is a wobble on the front wheel I take that is 1, the wheel bearing or 2, it the swivel pin/bearing gone on that, could it be anything else?

sorry for going on,

Regards JJ

Link to comment
Share on other sites

Hi Jonnigee, You caught me out there sorry I did not see your post as we have to wait for it to be approved lol, Thank you for the welcome sorry I car,nt answer in Welsh though!! I am a Welsh boy ( from Bethesda where you from?) but I am deaf in both ears so instead of learning Welsh I had to catch up on English, but we are learning to speak Welsh ( As partner is from Notts) so hope we can meet up and have a chin wag and a nice cuppa lol!

Link to comment
Share on other sites

Forgot to add do anyone perfer 200 or 300 tdi? My 200tdi needs welding as stated above, but the rear box part on the body not chassis need replacing and I seen 1 on e bay but at £130! Can I get 1 cheaper? If so do you know where from please, I would plate it but it already been plated and underside is not there just a pair of body mounts :blink:

The 300tdi is not running well it only starts with a bump, and there no power when you press the pedal, From what I have been reading on your forum, it mostly states the fuel lift is at fault. Do you still think that is right? The last owner was told it could be the relay? What do you think to that?

Also there is a wobble on the front wheel I take that is 1, the wheel bearing or 2, it the swivel pin/bearing gone on that, could it be anything else?

sorry for going on,

Regards JJ

i use this company called fenland rover its a breakers but he's cheap well, i think so and has always been helpfull so here the number he also has an ebay shop 01354742392

Link to comment
Share on other sites

Not a symptom of the lift pump - you lose top end, not starting.

Les.

I made a mistake sorry, It does start the message was the battery was flat and it start with a bump.

This was the message:

There is power loss at the accelerator,this has got worse since i stopped using the car at the end of August.Again i have never had this investigated so don`t know what`s causing it,someone i know said it could be an electrical/relay fault,worst case scenario it`s the fuel pump!

She`ll bump start but won`t start otherwise having been stood.

Sorry about that (Note To Myself READ Right First Time!)

Thanks for your input ......JJ

Link to comment
Share on other sites

Hi all again! Right I been to see the Discovery today and spoke to the owner and got to the bottom of the running problem,

Here is what is said In August last year he was driving it OK apart from letting go of the gas pedal it would start to hunt as if it was going to stall, but never did. so took it in to a mechanic he had a look. And said a number of things so the lift pump was replaced, all filters replaced and it still carried on, So that was left with a fuel pump or electrical problem but time was running out and in a hurry he got a new discovery. So this old Discovery was left on the field and the longer he left it there the worse it got, He was told that the Relay or pedal sensor is or could be faulty as he said when driving it OK and reaches top speed no problem no rev problems it just idling rough as if it is stalling but on a open run its fine. Also it DOES start from a key when the battery is fully charged.

Also there is a abs sensor faulty (Front) is there anyway of fixing it without taking it in to be plugged in to a machine?

Has anyone got any ideas?

This is a 1994 L reg ES model 300TDI with A/C if that is any help?

Regards JJ

Link to comment
Share on other sites

Allright jj, you've found the forums then!! See you tomorrow!

Hi Bud, was good to see ya! Sorry I did not do anything today. Hope I will get it done in the week, Dont worry about the axle I will strip it in the week if you dont have time ok. and I text you in the week .......JJ

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy