Jump to content

What the hell is it doing?


Recommended Posts

OK here it is folks. 300tdi, changed PAS pump three times now and the bugger won't run quiet. Stuck a couple of secondhand genuine ones on, bled up OK, ran nice and quiet for about 100 miles or so then whirrs away. Put on a cheapy new one and same again. Noticed a bit of perishing on high pressure hose so thought maybe there could be line contamination, changed all the hoses for new and put pump back on. Nice and quiet for about 100 miles again, then whirrs away.

There's a bit of a leak on the box bottom seal other than that the system seems fine and appears to bleed, just refuses to run quietly. Either I've been unlucky enough to have had 3 duff pumps or something else is going on. Been trying to get this licked for weeks!. Any ideas?.

Link to comment
Share on other sites

OK here it is folks. 300tdi, changed PAS pump three times now and the bugger won't run quiet. Stuck a couple of secondhand genuine ones on, bled up OK, ran nice and quiet for about 100 miles or so then whirrs away. Put on a cheapy new one and same again. Noticed a bit of perishing on high pressure hose so thought maybe there could be line contamination, changed all the hoses for new and put pump back on. Nice and quiet for about 100 miles again, then whirrs away.

There's a bit of a leak on the box bottom seal other than that the system seems fine and appears to bleed, just refuses to run quietly. Either I've been unlucky enough to have had 3 duff pumps or something else is going on. Been trying to get this licked for weeks!. Any ideas?.

HAD A PUMP DO THIS ,IN THE END CHANGED THE FLUID TO SLICK FIFTY POWER STEER FLUID HAS NEVER HAD ANY MORE TRUBLE .

Link to comment
Share on other sites

There was a DAYCO belt on it previously that I've changed for a new DAYCO one. Even tried moving the tensioner while the engine was running to see if that eased the noise at all, no difference.

The slick 50 idea sounds interested, I'll try anything cos this is driving me nuts.

If a collapsing hose did cause line conamination will this cause permanent damage to a pump?.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy