Jump to content
Sign in to follow this  
russ3120

stop n tail light

Recommended Posts

I have tail lights working, but no brake light when I press the brake pedal, am I being supid and is itt something realy simply?

many thanks

Share this post


Link to post
Share on other sites

could be either blown flaments in each bulb or blow fuses or a busted brake light switch or a wire connection broken or disconnected.

brake light switch is on the top rear of the brake servo/brake master cylinder assembly.

Share this post


Link to post
Share on other sites

could be either blown flaments in each bulb or blow fuses or a busted brake light switch or a wire connection broken or disconnected.

brake light switch is on the top rear of the brake servo/brake master cylinder assembly.

^^^ wot Western said, plus check the bullet connectors behind the covers at the back of the load compartment, they corrode on occasion.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy