Jump to content

discovery 2 lack of power


discosimon
 Share

Recommended Posts

hello if anyone can help me i have disco 2 td5 i've had a remap done as well egr bypass done for towing i've been loseing power i have looked a intercooler hoses and intercooler they seem ok i've been on a nanocon and autologic and all fine boost is ok changed my k&n filter as it was hissing put standard one in no hissing maf ok map sensor ok all small hoses to wastegate modulator fine and changed modulator to what next do not now........

Link to comment
Share on other sites

Have you checked the fuel pressure? A failing pump can affect max power as the pressure drops as demand increases. It won't show as a fault and the ECU can't measure the rail pressure - you need to put some sort of gauge or sensor into the fuel line and cane it up a hill under full load to check it properly.

Link to comment
Share on other sites

Have you checked the fuel pressure? A failing pump can affect max power as the pressure drops as demand increases. It won't show as a fault and the ECU can't measure the rail pressure - you need to put some sort of gauge or sensor into the fuel line and cane it up a hill under full load to check it properly.

thanks i'll try it

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy