Jump to content

Indicator relay


Recommended Posts

Hatty's indicator relay is playing up. Well, a bit. (Most of Hatty is a 1988 110)

In normal use it gives one flash of the trailer light along with the normal indicator warning then works normally.

With a trailer plugged in there's no trailer warning. But it works fine.

Now I have my old loom following a bulkhead swap with a full set of relays. And I'm sure it's the large transparent blue one full of wiggly amp stuff?

But a bit of reassurance would be nice before I brave the elastic-tricity stuff:)

Link to comment
Share on other sites

And I'm sure it's the large transparent blue one full of wiggly amp stuff

correct & most likely has Hella printed on it, should e attached to the bulkhead sie of the fusebox metal panel with a screw or bolt, not clipped along the bottom like the other relays.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy