Jump to content

Discovery Td5 Heater


Dougal667
 Share

Recommended Posts

Hullo all. I've a T plated Discovery Td5. None air-con model. When sitting in traffic the heater blows cold air, once you're off and running again it get's back to normal and blasts what ever temp you set the dial to from cold to hot. Just wondered if anyone has the same problem and what can be done about it. Thanks in advance.

Link to comment
Share on other sites

I have a 2001 Td5 with air con /climate control but I have noticed the same thing from time to time - cold air when idling, even though the engine is warm .

I find that if I bring the revs up to about 1000 the heater works fine . Would seem to be that on tick over the coolant is not circulating as well as it should - but have not done anything about it . Been that way since I got it about 3 yrs ago .

Link to comment
Share on other sites

  • 3 weeks later...

hello , same problem with mine 2004 , Discovery landmark with aircon , coolant level fine , oil clear , anybody any ideas , Some other forums ghave differnt theories re this which sems quite common , air lock ? , ? viscous fan cools too much at idle ????

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy